Bug 65660 - PostScript interpreter failed
PostScript interpreter failed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gv (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-29 13:18 EDT by jmbastia
Modified: 2014-03-16 22:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-14 10:51:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PostScript file that demonstrates the problem (88.13 KB, application/postscript)
2002-05-29 13:23 EDT, jmbastia
no flags Details
Another failing postscript file (23.14 KB, application/postscript)
2002-07-10 13:00 EDT, Laurence Tyler
no flags Details

  None (edit)
Description jmbastia 2002-05-29 13:18:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510

Description of problem:
When trying to view certain PostScript files with gv-3.5.8-15, an error dialog
box pops up with this:
  X Error of failed request:  BadMatch (invalid parameter attributes)
    Major opcode of failed request:  73 (X_GetImage)
    Serial number of failed request:  36
    Current serial number in output stream:  36

  Error: PostScript interpreter failed in main window.

This did not occur with the gv included in RedHat 7.1 and 7.2 with the same
PostScript files.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run 'gv' on a PostScript file
2. Observe the error message

	

Expected Results:  The PostScript file should have been viewable in gv's window.

Additional info:

It seems to occur only on PostScript files with embedded images, but I'm not
certain of that.
Comment 1 jmbastia 2002-05-29 13:23:43 EDT
Created attachment 58865 [details]
PostScript file that demonstrates the problem
Comment 2 Alexei Podtelezhnikov 2002-05-29 19:50:21 EDT
The component should be changed to ghostscript, since kghostview (KDE) fails to
do  do this too. Interestingly, ps2pdf works without a warning and the
resultiong pdf is rendered fine (isn't it?). I would also file this to
gs-bugs@ghostscript.com.
Comment 3 jmbastia 2002-05-30 11:39:22 EDT
ps2pdf does render the file correctly, and ggv almost renders it correctly (the
borders or bounding box are cut off on the bottom and right sides).
Comment 4 Laurence Tyler 2002-07-10 13:00:59 EDT
Created attachment 64616 [details]
Another failing postscript file
Comment 5 Laurence Tyler 2002-07-10 13:04:48 EDT
I've seen this problem as well. Strangely, it only seems to happen if GV is set
to 'automatic sizing' of the paper. If you invoke GV with '-media something', e.g.:
'gv -media a4 res_sheet.ps' it seems to work. Also, invoking 'gs res_sheet.ps'
directly from the shell (not using gv) also seems to work. Maybe GV is not
creating/passing to GS a valid X window or pixmap to write in? (I have no idea
how the innards work, this is just a guess...)
Comment 6 Laurence Tyler 2002-07-10 13:11:47 EDT
Hmm... seems you've fixed this in version -18, which I just installed from
RawHide. Apologies for telling you about something you had already fixed!
Comment 7 Peter Englmaier 2002-08-07 07:55:41 EDT
Here is another failing postscript file. 
To my knowledge it doesn't contain embedded images, just text.
It was created using staroffice.
http://www.mpe.mpg.de/~ppe/erlaubnis.ps

Interestingly, ghostscript can display the file, but gv cannot.
Versions (redhat 7.3):
$ rpm -q ghostscript gv ghostscript-fonts
ghostscript-6.52-9.4
gv-3.5.8-15
ghostscript-fonts-5.50-3

Best Wishes
Comment 8 jmbastia 2002-10-14 10:51:11 EDT
As lgt@dmu.ac.uk pointed out, gv-3.5.8-18 works fine.  I just grabbed the RPM
from RedHat 8.0 and installed it on my lab full of RedHat 7.3 machines without a
hitch.

You can probably close this bug.

Note You need to log in before you can comment on or make changes to this bug.