Bug 656600 - Please Update Spec File to use %ghost on files in /var/run and /var/lock
Please Update Spec File to use %ghost on files in /var/run and /var/lock
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
http://lists.fedoraproject.org/piperm...
:
Depends On:
Blocks: 827166 656625
  Show dependency treegraph
 
Reported: 2010-11-23 18:31 EST by Lennart Poettering
Modified: 2012-05-31 15:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-09 20:35:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2010-11-23 18:31:09 EST
Your package httpd appears to include a file in /var/run or /var/lock. With an upcoming change in Rawhide these directories will now be mounted as tmpfs. For details about this change please consult http://lists.fedoraproject.org/pipermail/devel-announce/2010-November/000726.html For your package this means that you need add %ghost to all files that are placed in either of these two directories. Please make sure to make this change in time for the F15 cycle. For details about %ghost see http://www.rpm.org/max-rpm-snapshot/s1-rpm-inside-files-list-directives.html#S3-RPM-INSIDE-FLIST-GHOST-DIRECTIVE , for more information on the F15 feature see the feature page https://fedoraproject.org/wiki/Features/var-run-tmpfs . If your package already uses %ghost on these files, feel free to close this bug report right-away. Sorry for this mass bug filing, and if you have any further questions, don't hesitate to ask on fedora-devel or ask me personally. Thank you, Lennart
Comment 1 Paul Howarth 2010-12-01 09:39:26 EST
Quick fix: add /etc/tmpfiles.d/httpd.conf containing the one line:

d	/var/run/httpd			710	root	apache

And add a dependency on systemd-units for ownership of the /etc/tmpfiles.d directory.
Comment 2 Joe Orton 2011-01-04 10:52:38 EST
Should /etc/tmpfiles.d/httpd.conf be marked %config, %config(noreplace), or not at all?
Comment 3 Joe Orton 2011-01-04 11:11:55 EST
http://koji.fedoraproject.org/koji/buildinfo?buildID=212576

does this work?
Comment 4 Paul Howarth 2011-01-04 11:50:31 EST
(In reply to comment #2)
> Should /etc/tmpfiles.d/httpd.conf be marked %config, %config(noreplace), or not
> at all?

I'd suggest not at all since there should be no reason to modify it at all, and any additional local entries could be added to a separate tmpfiles.d file. Not marking it as %config(noreplace) generates an rpmlint warning but I'd live with that.
Comment 5 Joe Orton 2011-01-04 12:17:22 EST
If this stuff isn't meant to be modifiable at all, it shouldn't be in /etc.
Comment 6 Lennart Poettering 2011-01-20 19:49:52 EST
Some of the conf files in /etc/tmpfiles.d might be valid to edit, for example, to change cleanup intervals and stuff like that. However, to the Apache case this doesn't really apply.

Note You need to log in before you can comment on or make changes to this bug.