This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 656611 - Provide /etc/tmpfiles.d/libvirt.conf so systemd+selinux+libvirt plays nice
Provide /etc/tmpfiles.d/libvirt.conf so systemd+selinux+libvirt plays nice
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
http://lists.fedoraproject.org/piperm...
: Reopened
Depends On:
Blocks: 758896 758897 788985
  Show dependency treegraph
 
Reported: 2010-11-23 18:32 EST by Lennart Poettering
Modified: 2016-03-22 18:50 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 758896 758897 (view as bug list)
Environment:
Last Closed: 2016-03-22 18:50:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2010-11-23 18:32:32 EST
Your package libvirt appears to include a file in /var/run or /var/lock. With an upcoming change in Rawhide these directories will now be mounted as tmpfs. For details about this change please consult http://lists.fedoraproject.org/pipermail/devel-announce/2010-November/000726.html For your package this means that you need add %ghost to all files that are placed in either of these two directories. Please make sure to make this change in time for the F15 cycle. For details about %ghost see http://www.rpm.org/max-rpm-snapshot/s1-rpm-inside-files-list-directives.html#S3-RPM-INSIDE-FLIST-GHOST-DIRECTIVE , for more information on the F15 feature see the feature page https://fedoraproject.org/wiki/Features/var-run-tmpfs . If your package already uses %ghost on these files, feel free to close this bug report right-away. Sorry for this mass bug filing, and if you have any further questions, don't hesitate to ask on fedora-devel or ask me personally. Thank you, Lennart
Comment 1 Fedora Admin XMLRPC Client 2011-09-22 13:49:46 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Admin XMLRPC Client 2011-09-22 13:52:43 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Admin XMLRPC Client 2011-09-22 13:57:59 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2011-11-30 14:30:26 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2011-11-30 14:34:07 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2011-11-30 14:40:32 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Fedora Admin XMLRPC Client 2011-11-30 14:51:43 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Eric Blake 2011-11-30 17:35:46 EST
Upstream patch proposed:
https://www.redhat.com/archives/libvir-list/2011-November/msg01840.html
Comment 9 Eric Blake 2011-12-01 13:07:33 EST
The next build will have this.

commit 764574f7c73d72e42f69f225b6bbe61fae5ab28b
Author: Eric Blake <eblake@redhat.com>
Date:   Wed Nov 30 15:34:42 2011 -0700

    spec: mark directories in /var/run as ghosts
    
    We have several directories that are created on the fly, and which
    only contain state relevant to a running libvirtd process (all
    located in /var/run).  Since the directories are created as needed,
    and make no sense without a running libvirtd, we want them deleted
    if libvirt is uninstalled.  And in F15 and newer, /var/run is on
    tmpfs (forcing us to recreate on the fly); which means that someone
    trying to verify a complete rpm will fail if the directory does not
    currently exist because libvirtd has not been started since boot.
    The solution, then, is to mark the directories as %ghost, so that
    rpm knows that we own them and will clean it up if libvirt is
    uninstalled, but will no longer create the directory for us at
    install, nor complain at verify time if the directory does not exist.
    
    See https://bugzilla.redhat.com/show_bug.cgi?id=656611.
    
    * libvirt.spec.in (%files): Add %ghost to temporary directories
    that we don't install, but want cleaned up on libvirt removal.
Comment 10 Eric Blake 2012-02-24 14:24:58 EST
Reopening - see bug 788985 - we also need to add /etc/tmpfiles.d/libvirt.conf when targetting systemd, in order for the temporary directory to get created with correct SELinux labels.
Comment 11 Cole Robinson 2013-04-01 07:01:35 EDT
Since this doesn't seem to have caused much issue in practice, and has lingered for a while, moving to the upstream tracker.
Comment 12 Cole Robinson 2016-03-22 18:50:28 EDT
I don't think there's actually anything left to do here... AFAIK our current setup hasn't caused any issues

Note You need to log in before you can comment on or make changes to this bug.