Bug 65662 - error when compiling kernel 2.4.18-4 (names.c)
error when compiling kernel 2.4.18-4 (names.c)
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-05-29 14:31 EDT by ArjanNutz
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-05-31 09:41:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
My kernel config (23.68 KB, text/plain)
2002-05-29 14:33 EDT, ArjanNutz
no flags Details

  None (edit)
Description ArjanNutz 2002-05-29 14:31:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; .NET CLR 1.0.3705)

Description of problem:
When I compile my kernel I get:
names.c:55: Internal error: Segmentation fault

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. make oldconfig
2. make menuconfig
3. make dep
4. make clean
5. make bzImage

Actual Results:  the same error

Additional info:

the error:

names.c:55: Internal error: Segmentation fault
Please submit a full bug report
e[3]: *** [names.o] Error 1
make[3]: Leaving directory `/usr/src/linux-2.4.18-4/drivers/pci'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.18-4/drivers/pci'
make[1]: *** [_subdir_pci] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.18-4/drivers'
make: *** [_dir_drivers] Error 2

kernel: 2.4.18-4
gcc: 2.96-110
Comment 1 ArjanNutz 2002-05-29 14:33:02 EDT
Created attachment 58866 [details]
My kernel config
Comment 2 Jakub Jelinek 2002-05-31 09:41:40 EDT
Is it reproduceable, always on the same file same error.
If yes, you need to provide preprocessed source, if not, it is likely a hardware

Note You need to log in before you can comment on or make changes to this bug.