Bug 65669 - Xine locks up system when it gets loaded
Xine locks up system when it gets loaded
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: xine (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: wdovlrrw
http://www.quicktime.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-29 16:46 EDT by cool_1
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-27 08:51:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description cool_1 2002-05-29 16:46:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
Whenever I attempt to view video content in Mozilla and it loads up xine, the
system locks up and won't respond to the mouse or keyboard.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Log in, start up Mozilla
2.Browse to http://www.quicktime.com/
3.Curse and stamp feet
	

Actual Results:  System locked up.

Expected Results:  I wanted to view video content.

Additional info:
Comment 1 Scott Dowdle 2002-06-04 10:44:38 EDT
Ummm, xine WILL NOT VIEW Apple(tm) Quicktime(tm) .mov files... especially not
modern ones... not that I'm aware of.  So basically your report says that you
can't drive a nail with a plastic spoon.

Anything beyond Quicktime 3 is generally problematic without the real Quicktime
player from Apple... sorenson compression don't you know.

The work around is to download the trail version of CodeWeaver's CrossOver
Pluggin and see if it works for you (works for me)... and then buy it.
Comment 2 cool_1 2002-06-04 13:53:31 EDT
Hmmm.  That's a good point, but it still doesn't explain the full extent of the 
lock up behavior.

I've also observed the behavior while attempting to view .mpg or .mpeg 
extension files.

When I load xine from the comman line, it completely locks up the system.  My 
mouse cursor dissapears and the application will not respond to any keyboard 
commands.  I'm not really sure there isn't an error message window somewhere, 
since I can't move anything on the screen.  The Xine logo window doesn't even 
have focus.

Is this a problem with the lack of a Mozilla plug-in?  The Red Hat 7.3 
Distribution comes with xine 9.8.2, I'm going to try installing 9.10 to see if 
that fixes the problem.
Comment 3 Scott Dowdle 2002-06-04 16:06:54 EDT
What sound card do you have?  Does it function ok outside of xine?  By default,
xine tries to load/use esd I think.  Try running it without sound.  Try
different  video options.  Yeah, I know that doesn't explain the lockup.  I'm
wondering if it is really locked or not.  Can you ping it over a network, can
you ssh in (assuming you have sshd running)?  I run the non-GPL, binary only
nVidia driver and it tends to lockup every once in a while... and often I can
access the machine remotely and restart X.  Again, not solutions but potential
symptom work arounds.
Comment 4 cool_1 2002-06-06 17:05:11 EDT
I'm running the VIA Technologies via82C686 AC97 Audio Controller.

It's installed on the motherboard of my ASUS Terminator Barebones system that 
I've outfitted with a 1.1GHz Duron and 256MB of RAM.

The sound card works fine, I can play CD's, but with a different program.  I 
just enabled telnet on the box, so the next time it locks up I can try your 
workarounds.

I installed the binary CVS RPM from Freshrpms for Xine 9.10.  No joy.
Comment 5 cool_1 2002-06-20 01:05:01 EDT
Additional info -

XMMS works great on mp3's.  No sound problems.
Following Xine lockup, cannot ping or telnet to system, lockup is complete.

Still trying to figure this one out.

Xine --help reveals:
Available video drivers: Xv, SyncFB, XShm
Available audio drivers: null, oss, esd, arts

Is there a log I can examine for possible error messages?
Comment 6 cool_1 2002-06-20 05:34:23 EDT
Latest news:

Probing on the xine-user mailing list on SourceForge.net revealed other users 
with similar problems.

I obtained the source for xine-lib and xine-ui 0.9.10 and created a debug 
enabled version.  Following the messages as this was loaded revealed the freeze 
occured as xine was loading the Xv video output plugin.

Further browsing of the mailing list archive revealed problems related 
to "Savage" drivers, which came up in the debug output.  Further investigation 
revealed that the motherboard chipset on my system uses an integrated Via chip 
which includes built in S3 Savage 4Graphics.

Running:

xine -V xshm

solves the problem.  Now I need to figure out how to make this the default when 
ever xine is loaded from mozilla to play video content.

I'm also looking for an update of the XFree86 Xv library that fixes the Savage 
bug.
Comment 7 TSO ALAN LUNG HOI 2003-04-20 12:21:08 EDT
SAME PROBLEM. SYSTEM STOPS WHEN xine IS LOADED.
Comment 8 Karsten Hopp 2004-01-27 08:51:56 EST
xine isn't part of any supported product from Red Hat anymore. If the
problem still exists with latest packages from sourceforge, please
report it there.

Note You need to log in before you can comment on or make changes to this bug.