Bug 656695 - Please Update Spec File to use %ghost on files in /var/run and /var/lock
Please Update Spec File to use %ghost on files in /var/run and /var/lock
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spice-vdagent (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
http://lists.fedoraproject.org/piperm...
:
Depends On:
Blocks: 827166
  Show dependency treegraph
 
Reported: 2010-11-23 18:43 EST by Lennart Poettering
Modified: 2012-05-31 15:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: spice-vdagent-0.8.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-24 22:41:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
tmpfiles.d configuration for space-vdagentd (41 bytes, text/plain)
2011-04-19 04:48 EDT, Tom Hughes
no flags Details

  None (edit)
Description Lennart Poettering 2010-11-23 18:43:05 EST
Your package spice-vdagent appears to include a file in /var/run or /var/lock. With an upcoming change in Rawhide these directories will now be mounted as tmpfs. For details about this change please consult http://lists.fedoraproject.org/pipermail/devel-announce/2010-November/000726.html For your package this means that you need add %ghost to all files that are placed in either of these two directories. Please make sure to make this change in time for the F15 cycle. For details about %ghost see http://www.rpm.org/max-rpm-snapshot/s1-rpm-inside-files-list-directives.html#S3-RPM-INSIDE-FLIST-GHOST-DIRECTIVE , for more information on the F15 feature see the feature page https://fedoraproject.org/wiki/Features/var-run-tmpfs . If your package already uses %ghost on these files, feel free to close this bug report right-away. Sorry for this mass bug filing, and if you have any further questions, don't hesitate to ask on fedora-devel or ask me personally. Thank you, Lennart
Comment 1 Tom Hughes 2011-04-19 04:46:45 EDT
It's actually worse than just needing to add %ghost to the spec...

Because spice-vdagent has a directory in /var/run which is created by the RPM installation it actually fails to start in F15 due to the directory not existing.

So spice-vdagentd either needs to create /var/run/spice-vdagentd itself on startup, or the rpm needs to ship an file in /etc/tmpfiles.d to make sure systemd creates it on startup.
Comment 2 Tom Hughes 2011-04-19 04:48:11 EDT
Created attachment 493131 [details]
tmpfiles.d configuration for space-vdagentd
Comment 3 Hans de Goede 2011-04-20 04:04:50 EDT
(In reply to comment #2)
> Created attachment 493131 [details]
> tmpfiles.d configuration for space-vdagentd

Thanks!

Note I've not used you're file, since I very recently added a tmpfiles.d file to spice-vdagent upstream git already.

I've released spice-vdagent 0.8.0 today, which includes this fix. You can expect an update for F-15 for this any minute now...

Regards,

Hans
Comment 4 Fedora Update System 2011-04-20 04:05:45 EDT
spice-vdagent-0.8.0-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/spice-vdagent-0.8.0-1.fc14
Comment 5 Fedora Update System 2011-04-20 04:06:30 EDT
spice-vdagent-0.8.0-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/spice-vdagent-0.8.0-1.fc15
Comment 6 Fedora Update System 2011-04-20 22:59:38 EDT
Package spice-vdagent-0.8.0-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spice-vdagent-0.8.0-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/spice-vdagent-0.8.0-1.fc15
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2011-04-24 22:41:52 EDT
spice-vdagent-0.8.0-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.