Bug 6567 - FTP and HTTP upgrades 6.0 -> 6.1 fail after rebuilding RPM database
FTP and HTTP upgrades 6.0 -> 6.1 fail after rebuilding RPM database
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
Depends On:
  Show dependency treegraph
Reported: 1999-10-31 09:13 EST by spam
Modified: 2015-01-07 18:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-11-01 09:41:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description spam 1999-10-31 09:13:29 EST
I have tried unsuccessfully to upgrade from RH 6.0 -> 6.1
using both FTP and HTTP. Both fail at the same location,
right after the stage where the installer rebuilds the RPM

I am using the UPDATED network boot disk.

Here is the error message:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 225, in ?
    intf.run(todo, test = test)
  File "/tmp/lib/python1.5/site-packages/text.py", line
1000, in run
  rc = apply (step[1](), step[2])
  File "/tmp/lib/python1.5/site-packages/text.py", line 572,
in __call__
    if todo.doInstall ():
  File "/tmp/lib/python1.5/site-packages/todo.py", line
1465, in doInstall
    self.instLog = open(self.instPath + logname, "w+")
  IOError: [Errno 2] No such file or directory:
Comment 1 Jay Turner 1999-11-01 09:41:59 EST
My guess is that you have the /tmp directory symlinked to a different
location and this is causing problems with the installer.  The install
program is only able to follow relative symlinks, so I am guessing
this is an absolute symlink that you have.  Converting it to a
relative link will solve the problem.  Reopen this bug if your
problems are not solved by changing to a relative symlink.

Note You need to log in before you can comment on or make changes to this bug.