Bug 656852 - [abrt] byobu-3.4-2.fc14: byobu-config:377:writewindows:IOError: [Errno 2] No such file or directory: '/home/costa/.byobu/windows'
Summary: [abrt] byobu-3.4-2.fc14: byobu-config:377:writewindows:IOError: [Errno 2] No ...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: byobu
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Jan Klepek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:fea8520a
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-24 11:18 UTC by Andre Costa
Modified: 2012-09-17 23:44 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-08-17 01:11:44 UTC


Attachments (Terms of Use)
File: backtrace (761 bytes, text/plain)
2010-11-24 11:18 UTC, Andre Costa
no flags Details

Description Andre Costa 2010-11-24 11:18:09 UTC
abrt version: 1.1.14
architecture: x86_64
cmdline: /usr/bin/python /usr/bin/byobu-config
comment: Happens 100% of the time
component: byobu
executable: /usr/bin/byobu-config
kernel: 2.6.35.6-48.fc14.x86_64
package: byobu-3.4-2.fc14
reason: byobu-config:377:writewindows:IOError: [Errno 2] No such file or directory: '/home/costa/.byobu/windows'
release: Fedora release 14 (Laughlin)
time: 1290597453
uid: 500

backtrace
-----
byobu-config:377:writewindows:IOError: [Errno 2] No such file or directory: '/home/costa/.byobu/windows'

Traceback (most recent call last):
  File "/usr/bin/byobu-config", line 562, in <module>
    if __name__ == "__main__": main()
  File "/usr/bin/byobu-config", line 553, in main
    tag = defaultwindows(screen, size)
  File "/usr/bin/byobu-config", line 416, in defaultwindows
    writewindows(winlist)
  File "/usr/bin/byobu-config", line 377, in writewindows
    f=open(HOME+'/.'+PKG+'/windows', 'w')
IOError: [Errno 2] No such file or directory: '/home/costa/.byobu/windows'

Local variables in innermost frame:
winlist: [[-1, '# Default windows examples\n'], [1, 'screen -t top top\n'], [0, 'screen -t web w3m\n'], [0, 'screen -t shell motd+shell\n']]

How to reproduce
-----
1.open byobu-config
2.choose "Manage default windows"
3.check 1st option ("screen -t top top")
4.apply changes

Comment 1 Andre Costa 2010-11-24 11:18:12 UTC
Created attachment 462597 [details]
File: backtrace

Comment 2 Fedora Update System 2011-01-08 12:58:57 UTC
byobu-3.21-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/byobu-3.21-1.fc13

Comment 3 Fedora Update System 2011-01-08 12:59:12 UTC
byobu-3.21-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/byobu-3.21-1.fc14

Comment 4 Fedora Update System 2011-01-08 12:59:27 UTC
byobu-3.21-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/byobu-3.21-1.el5

Comment 5 Fedora Update System 2011-01-08 12:59:43 UTC
byobu-3.21-1.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/byobu-3.21-1.el4

Comment 6 Fedora Update System 2011-01-08 18:06:29 UTC
byobu-3.21-1.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update byobu'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/byobu-3.21-1.el4

Comment 7 Jan Klepek 2011-01-11 11:50:22 UTC
Could you please test byobu which is in update repository if this fixes your issue?

su -c 'yum --enablerepo=updates-testing update byobu'.  

You can provide
feedback for this update here:
F13:
https://admin.fedoraproject.org/updates/byobu-3.21-1.fc13
F14:
https://admin.fedoraproject.org/updates/byobu-3.21-1.fc14

Comment 8 Andre Costa 2011-01-11 12:03:46 UTC
Hi Jan, thks for helping.

I just tried the new version, no luck :-(

               Traceback (most recent call last):
                                                   File "/usr/bin/byobu-config", line 578, in <module>
                          if __name__ == "__main__": main()
                                                             File "/usr/bin/byobu-config", line 569, in main
                                tag = defaultwindows(screen, size)
                                                                    File "/usr/bin/byobu-config", line 432, in defaultwindows
                                                 writewindows(winlist)
                                                                        File "/usr/bin/byobu-config", line 393, in writewindowscts | <Esc> exits
                                                   f=open(DATA+'/windows', 'w')
                                                                               IOError: [Errno 2] No such file or directory: '/home/costa/.byobu/windows'

The version seems to be correct:


~ rpm -q byobu
byobu-3.21-1.fc14.noarch

(ABRT detected the crash again, but I am assuming it will be a duplicate; should I try to report it anyway?)

Comment 9 Jan Klepek 2011-01-11 12:45:50 UTC
not needed to report it, I'm working on it.

Comment 10 Fedora Update System 2011-08-02 08:47:42 UTC
byobu-4.23-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/byobu-4.23-1.fc14

Comment 11 Fedora Update System 2011-08-02 08:48:11 UTC
byobu-4.23-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/byobu-4.23-1.fc15

Comment 12 Fedora Update System 2011-08-17 01:11:19 UTC
byobu-4.23-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-08-17 01:19:52 UTC
byobu-4.23-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2012-08-25 17:58:04 UTC
byobu-5.21-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/byobu-5.21-4.el6

Comment 15 Fedora Update System 2012-08-25 17:58:41 UTC
byobu-5.21-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/byobu-5.21-4.fc17

Comment 16 Fedora Update System 2012-08-25 17:59:11 UTC
byobu-5.21-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/byobu-5.21-4.el5

Comment 17 Fedora Update System 2012-08-25 17:59:42 UTC
byobu-5.21-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/byobu-5.21-4.fc18

Comment 18 Fedora Update System 2012-09-03 00:48:50 UTC
byobu-5.21-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2012-09-09 18:33:35 UTC
byobu-5.21-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2012-09-09 18:34:24 UTC
byobu-5.21-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2012-09-17 23:44:46 UTC
byobu-5.21-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.