Bug 65687 - HPLaserJet4L print errors
HPLaserJet4L print errors
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2002-05-29 21:54 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-07-31 09:49:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Requested file (598 bytes, application/octet-stream)
2002-06-24 17:52 EDT, Need Real Name
no flags Details
Requested print file (598 bytes, application/octet-stream)
2002-06-27 10:46 EDT, Need Real Name
no flags Details
/etc/alchemist/namespace/printconf/local.adl using laserjet driver (638 bytes, application/octet-stream)
2002-07-26 12:49 EDT, Need Real Name
no flags Details
/etc/alchemist/namespace/printconf/local.adl using ljet4 driver (635 bytes, application/octet-stream)
2002-07-26 12:50 EDT, Need Real Name
no flags Details
A mapquest page using RedHat 6.9.5 lj4dith driver (a good result) (283.30 KB, image/gif)
2002-07-26 12:51 EDT, Need Real Name
no flags Details
The same page using RedHat 7.3 laserjet driver (smearing problems) (293.10 KB, image/gif)
2002-07-26 12:52 EDT, Need Real Name
no flags Details
The same page using RedHat 7.3 ljet4 driver (corrupt) (87.73 KB, image/gif)
2002-07-26 12:53 EDT, Need Real Name
no flags Details
The RedHat 7.3 Postscript test page using ljet4 driver (corrupt) (68.53 KB, image/gif)
2002-07-26 12:53 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-05-29 21:54:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-3 i586)

Description of problem:
HPLaserJet4L still works fine under RH-6.0 with LaserJet-laserjet filter.  Fails
under RH-7.2 and 7.3.  In latter puts characters periodically in left margin and
in those lines smears characters across page.  Originally had 1Mb memory on
printer. Now upgraded to 2Mb.  Has no visible effect in 6.0,7.2 or 7.3.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Any printing.

Additional info:
Comment 1 Need Real Name 2002-06-03 12:27:05 EDT
I have had no response in 5 days.

Is there a simple solution of replacing components (e.g. ghostview/ghostscript)
from RedHat-6.0 in RedHat-7.3?  I purchased RedHat-6.0,6.1,7.0,7.1,7.2 disks
from you so have source as well as binaries.
Comment 2 Tim Waugh 2002-06-18 08:28:13 EDT
Please attach the /etc/alchemist/namespace/printconf/local.adl file from an  
installed 7.3 machine with a print queue set up for this printer.  Does the 
test page have the same artifacts on the page? 
(Changing version to 7.3, the latest one mentioned in your report.)
Comment 3 Need Real Name 2002-06-24 13:19:32 EDT
local.adl using "laserjet"
^_<8B^@^@^@^@^@^@^CmVAnb0^P=s^UQ> ^AJ[U^B*,
U$@*$TjI2^R^C^9q6v*n_oD<90>B<88><81>e<8B>TK^"g^{cqLS^L<9F>>Rf<<93>BP<9E><8D>L^MW|^Zw<86>8IQL3I>$qj^D!kOGfW^\w^LcH^ScnO<9C><91>Ix<8C><99>i<84>N`Z^^`;}Acm]C^? b
2+^Y34_^VM^TS<82>%<96>^E![c< <99>^DU%^Q==^@?g<86>Q<96>*~<8B>~<95>$$B^W^@!k\0#^?fNFf^T,^\S^_^F<81><98>Q,^P#B^Zv\<9F>?M|Ex^FS%=<83>5XTNH~NI^V^\F<81>;^?6<8D>W[[T\~DvLK<83>)
pBP^U^X)<8B><93>^B%d<9D>FG$,xi1<[T)r^   5t<97><94>)NS  
WyaB<8A>8 yEphM^X^T)d
<91>dgXT7Yz[;~t<89>0%<8A>yP`ty"efS^?fGn$},<9B>wW<9D>u^D[^FU^<93>/Et{<8F>^Ow-TJ $ P1=<88>aA<8A><9F>D6Sd<E<92>FPpK\2).<98>Q<80>s\<82><95>U`S!<95>+atH^U^B"8++*v
local.adl using "ljet4"
U<9E>^W@s<92><83>&\e<89>^K)^V9M.<82>CkB H%<8B>$?C":IR_Zq#K<84>-UL#^B'K^S-7<9D>xS;rGugY<;j,^Fl^]4k@<98>|-"^?^?ww[C-^D<8A>s
Comment 4 Tim Waugh 2002-06-24 13:22:38 EDT
Please use the 'create a new attachment' link so that it doesn't get garbled.
Comment 5 Need Real Name 2002-06-24 17:52:12 EDT
Created attachment 62425 [details]
Requested file
Comment 6 Need Real Name 2002-06-27 10:46:33 EDT
Created attachment 62865 [details]
Requested print file
Comment 7 Tim Waugh 2002-06-27 12:24:28 EDT
Try using the "Laserjet 4L"->ljet4, gimp-print, or omni drivers.
Comment 8 Need Real Name 2002-06-28 11:46:50 EDT
I have tried them all.  ljet4 and laserjet give best output but not the quality of  
laserjet under RedHat-6.0.  It appears that random lines get garbled.  As I
wrote originally, in those random lines pixels get displaced (apparently to the
right) so the worst lines are difficult to decipher.  I never had a problem
until the RedHat-7x series.  Early Slackware and RedHat versions ran fine (I'm
currently transferring my print jobs to an older machine running RH-6.0) using
the same printer.  I have not tried more recent versions of other diatributions.
Comment 9 Need Real Name 2002-07-25 19:09:37 EDT
Has anyone found a solution to this problem?  

I am havign the same problem.  Everything worked well under RedHat 6.9.5
(Pinstripe), but fails with 7.3.  

I have a LaserJet 1100.  For me, any text (of any standard font) always prints
fine.  However, when there are any graphics on the page, parts of the graphics
are heavily pixelated (scan-lines are "smeared") and random characters appear
along the left margin on each affected line.

I have tried the same things that the person reported tried, with no
solution...   Any thoughts?
Comment 10 Tim Waugh 2002-07-26 02:55:54 EDT
redhat@leventon.com: Please attach your  
/etc/alchemist/namespace/printconf/local.adl file too.  Also, are you using 
the 'ljet4' driver (which is the recommended one for that printer model)?
Comment 11 Need Real Name 2002-07-26 12:48:35 EDT
I am using the Laserjet/laserjet driver.  The ljet4 driver does not work for
me.  It prints about 10% of the first page and then prints junk characters and
leaves junk in the printer buffer.  

I will attach the local.adl files for both using the laserjet and ljet4 drivers.

Also, I printed and then scanned in four pages.

1.  page-RH6-lj4dith.gif
     A mapquest page using RedHat 6.9.5 lj4dith driver
2.  page-RH7-laserjet.gif 
     The same page using RedHat 7.3 laserjet driver
3.  page-RH7-ljet4.gif  
     The same page using RedHat 7.3 ljet4 driver
4.  RH7-ps-test-ljet4.gif
     The RedHat 7.3 Postscript test page using ljet4 driver

(The Test page prints fine using the laserjet driver)

I will attach the gif images of the scanned-in pages.  Notice in #2 the smearing
of the text in Line 10 of the directions

Comment 12 Need Real Name 2002-07-26 12:49:39 EDT
Created attachment 67244 [details]
/etc/alchemist/namespace/printconf/local.adl using laserjet driver
Comment 13 Need Real Name 2002-07-26 12:50:19 EDT
Created attachment 67245 [details]
/etc/alchemist/namespace/printconf/local.adl using ljet4 driver
Comment 14 Need Real Name 2002-07-26 12:51:28 EDT
Created attachment 67246 [details]
A mapquest page using RedHat 6.9.5 lj4dith driver (a good result)
Comment 15 Need Real Name 2002-07-26 12:52:19 EDT
Created attachment 67247 [details]
The same page using RedHat 7.3 laserjet driver (smearing problems)
Comment 16 Need Real Name 2002-07-26 12:53:00 EDT
Created attachment 67248 [details]
The same page using RedHat 7.3 ljet4 driver (corrupt)
Comment 17 Need Real Name 2002-07-26 12:53:34 EDT
Created attachment 67249 [details]
The RedHat 7.3 Postscript test page using ljet4 driver (corrupt)
Comment 18 Tim Waugh 2002-07-27 06:25:02 EDT
Please try this:  
gs -q -dBATCH -dSAFER -dNOPAUSE -sDEVICE=ljet4 -sOutputFile=output.ljet4 \  
and then set up a RAW print queue for the HPLJ4L and print output.ljet4 to it. 
(Or for someone who wants to try this with a locally-attached printer, do: 
'cat output.ljet4 > /dev/lp0'). 
Let me know if _that_ works. 
Also, if you save a PostScript file of a web page that you want to print 
(print to file), and print that afterwards, are the smears always in the same 
places?  Could you attach that file please?
Comment 19 Need Real Name 2002-07-31 09:49:24 EDT
Problem Solved!   Thank you for your help.

I was using the printer via SMB share connection, and the "Translate \n => \r\n"
option was selected.  When I de-selected that option, everything works fine.

The "Laserjet/laserjet" driver no longer prints the random characters along the
left margin and no longer smears the lines containing graphics.  (Presumably
this was due to the extra \r's).

The "ljet4" driver now prints everything correctly (and at a higher resolution
than the Laserjet/laserjet driver).

Based on your suggestion, I connected the printer directly to the parallel port,
and everything worked fine, so I began debugging the SMB connection.  Strange
that the default SMB connection has CR/LF translation on.  I had just kept the
default and was only changing the Driver and Driver Options...

For me, the problem is resolved.
Comment 20 Tim Waugh 2002-08-05 12:09:42 EDT
(This option defaults to 'off' in the current beta.)

Note You need to log in before you can comment on or make changes to this bug.