Bug 656886 - provide native aiccu.service systemd file
provide native aiccu.service systemd file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: aiccu (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2010-11-24 08:38 EST by Tomasz Torcz
Modified: 2013-02-04 04:06 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-18 12:23:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
aiccu.service - systemd service definition (620 bytes, text/plain)
2010-11-24 08:38 EST, Tomasz Torcz
no flags Details
another proposal for aiccu.service (342 bytes, text/plain)
2011-06-12 09:17 EDT, Lukas Middendorf
no flags Details

  None (edit)
Description Tomasz Torcz 2010-11-24 08:38:09 EST
Created attachment 462618 [details]
aiccu.service - systemd service definition

The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to installing systemd Service files.

1.http://fedoraproject.org/wiki/Features/systemd
2.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/Daemon#Installing_Systemd_Service_Files

If you have any question dont hesitate to ask them on this bug report.


For optimal performance, please set “daemonize” to “false” in shipped default aiccu.conf.
Comment 1 Lukas Middendorf 2011-06-12 09:17:12 EDT
Created attachment 504306 [details]
another proposal for aiccu.service

After=aiccu.service should ensure that a service is only started after aiccu has done its work (set up ipv6 tunnels). That is not possible with "daemonize false" (at least not without hacking some kind of aiccu-wait.service). So I object against the original proposal and would like to propose a service file that works with "daemonize true".
My proposal works like the original sysV init script, everything that is to start after aiccu.service really waits for it until the tunnels are set up. Also "Require" is save to use now (with the original proposal services requiring aiccu.service might already have been started when aiccu fails)

The original proposal does not work with "daemonize false" so this breaks any existing configuration on updates and it is not just a matter of "optimal performance".

Other changes of my proposal compared to the original one:
1. /etc/sysconfig/aiccu is optional. add a "-" in the service file to allow startup with it absent.
2. Restart=no is the default so drop that part

You might want to readd the After-dependence on time-sync.target from the original init script. Also a "Before=multi-user.target" might be good.


Because aiccu provides some sort of network connections it might even be worth considering to start aiccu.service a little bit earlier like this:

After=iptables.service ip6tables.service network.service NetworkManager.service NetworkManager-wait-online.service
Before=network.target
Comment 2 Jochen Schmitt 2011-07-06 16:37:56 EDT
Ping Conrad

If you are busy, I may help out as an provenpackager
Comment 3 Conrad Meyer 2011-07-08 11:35:03 EDT
Jochen,

Please, go ahead. I am not as familiar with systemd as I would like to be, and am also unfortunately low in free time at present.

Thanks.
Comment 4 Lukas Middendorf 2011-07-18 11:34:04 EDT
I have found aiccu-2007.01.15-9.fc16 on koji. Is there any good reason to not use
EnvironmentFile=-/etc/sysconfig/aiccu
but instead create an empty /etc/sysconfig/aiccu and use
EnvironmentFile=/etc/sysconfig/aiccu
? The only use of the file I see would be to give the file name of a different config file. And if you are able to figure out yourself how to do that, you will also be able to create that file.

Something else I noticed: the /var/run/aiccu.pid in the default /etc/aiccu.conf should also have the "/var" removed.
Comment 5 Jochen Schmitt 2011-07-18 12:23:56 EDT
@Lukas,

Thank you for your helpful comments. I have fixed this in aiccu-2001.01.15-9.fc16.

Note You need to log in before you can comment on or make changes to this bug.