Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 656896 - libglade-WARNING in subscription-manager-gui
Summary: libglade-WARNING in subscription-manager-gui
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: J.C. Molet
URL:
Whiteboard:
: 703643 (view as bug list)
Depends On:
Blocks: 738066 756082
TreeView+ depends on / blocked
 
Reported: 2010-11-24 13:56 UTC by Miroslav Suchý
Modified: 2012-06-20 12:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 12:56:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
swapped patch (2.10 KB, patch)
2012-02-13 11:19 UTC, Miroslav Suchý
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0804 0 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2012-06-19 19:51:31 UTC

Description Miroslav Suchý 2010-11-24 13:56:10 UTC
Description of problem:
When I start subscription-manager-gui I got lots of warnings on stdout.

Version-Release number of selected component (if applicable):
subscription-manager-0.93.2-1.git.1.c76a8b0.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. run subscription-manager on rhel6
  
Actual results:
[root@dri/~]# subscription-manager-gui

(subscription-manager-gui:9196): libglade-WARNING **: Unexpected element <property> inside <widget>.

(subscription-manager-gui:9196): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:9196): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:9196): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:9196): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:9196): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:9196): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:9196): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:9196): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:9196): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:9196): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:9196): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:9196): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:9196): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:9196): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:9196): libglade-WARNING **: unknown attribute `swapped' for <signal>.

Expected results:
no errors

Comment 3 RHEL Program Management 2011-09-13 19:25:12 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Comment 6 Bryan Kearney 2011-11-21 17:51:38 UTC
*** Bug 703643 has been marked as a duplicate of this bug. ***

Comment 8 Miroslav Suchý 2012-02-13 11:17:32 UTC
Negative. We should care about warning. This is trivial issue. I will try to spend 10 minutes on this issue.
However feel free to flip this bz to fedora or comunity version of subscription-manager.

swapped attribute is not needed:
http://stackoverflow.com/questions/7827310/how-do-i-fix-the-unknown-attribute-swapped-warnings-from-libglade

Comment 9 Miroslav Suchý 2012-02-13 11:19:08 UTC
Created attachment 561505 [details]
swapped patch

patch fixing issue with
(subscription-manager-gui:23411): libglade-WARNING **: unknown attribute `swapped' for <signal>.

Comment 10 Miroslav Suchý 2012-02-13 12:34:05 UTC
problem with:
(subscription-manager-gui:9196): libglade-WARNING **: Unexpected element
<property> inside <widget>.
is not present in current HEAD of git://git.fedorahosted.org/subscription-manager.git
it is caused by tag <signal> which is in some .glade file present *before* <property> tag. And in glade order matters.
First must be all instances of <property> and then <signal>.
I tried to find such case, but did not find it within my timeframe I dedicated it for this BZ.

Comment 11 Bryan Kearney 2012-02-22 19:20:58 UTC
Applied in master at ff25f5c3354a83d407734b94dc63e54c12436630.  Thank you for the patch!

Comment 12 J.C. Molet 2012-02-27 14:48:34 UTC
Testing against version: subscription-manager-gnome-0.99.8-1.git.18.e98707c.el6.x86_64

================================

[root@jmolet-vm0 ~]# subscription-manager-gui 
/usr/sbin/subscription-manager-gui:31: DeprecationWarning: The dbus_bindings module is not public API and will go away soon.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  import dbus.dbus_bindings
/usr/share/rhsm/subscription_manager/gui/widgets.py:245: Warning: g_object_unref: assertion `G_IS_OBJECT (object)' failed
  self.glade.get_widget(widget_prefix + "_text").destroy()

============

No 'libglade-WARNING's were displayed in the above invocation.  Marking VERIFIED.

Comment 14 errata-xmlrpc 2012-06-20 12:56:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html


Note You need to log in before you can comment on or make changes to this bug.