Bug 65694 - IMAP connections fail
IMAP connections fail
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: imap (Show other bugs)
7.3
All Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-30 04:37 EDT by Elson, Del
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-10 19:53:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Elson, Del 2002-05-30 04:37:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
After updating to RH73, a new bug popped up where PHP was checking the validity
of the mail server certificate even for NON-SSL sessions. This was fixed, if you
can call it that, by adding "novalidate-cert" to non-ssl mail server call
string, even though this should not be necessary.

This bug also appears to be triggered by updating to the latest php_imap and
imap RPMs for Red Hat 7.2.  It appears to be caused by compiling php_imap
against imap-devel-2001c, so is possibly a bug in the IMAP libraries and not the
IMAP server.  Earlier versions of php_imap also exhibit this bug if recompiled
against imap-devel-2001c.  External IMAP clients (eg: Netscape communicator, MS
Outlook) appear to be unaffected.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Any php_imap compiled against imap-2001c libraries as supplied in
RH 7.3 or latest updates to RH 7.2.
2. imap_open ( {INBOX:443}, username, password );  -- fails
3. imap_open ( {INBOX:443/novalidate-cert}, username, password ); -- works

	

Actual Results:  Warning:  cannot open IMAP stream. (PHP error message).


Expected Results:  Successful opening of IMAP connection.


Additional info:

Note that adding the /novalidate-cert option to non-SSL imap connections prior
to imap-2001c appears to break them, eg:

I get this error:

source: email class.mail_msg_base.inc.php
called from: /phpGroupWare/index.php, index_data()
imap_last_error: Can't open mailbox
INBOX: invalid remote specification
Comment 1 Mike A. Harris 2002-05-30 17:38:37 EDT
For the record, there is no such thing as imap-2001c, at least not released
by Red Hat.  Perhaps you've made a typo?  Please confirm/correct, so we
are on the same page.

Assuming a typo...  I would wager that this is not an imap package problem,
but a php_imap problem.
Comment 2 Elson, Del 2002-05-30 20:43:50 EDT
The exact package name-version-release on Red Hat 7.2 is imap-2001a-1.72.0

The package on Red Hat 7.3 is imap-2001a-10

I agree that this could be a php_imap bug rather than an imap bug, but it seems
odd that compiling php_imap against imap-2001a causes the problem whereas
compiling it against imap-2000c-10 causes it to work correctly, whereas
compiling it against imap-2001a causes it to break.

It's not an imap server problem, since other IMAP clients are unaffected.
Comment 3 Elson, Del 2002-06-10 19:53:29 EDT
Has there been any action on this?  It still appears to be outstanding and
breaks most PHP based web mail systems.
Comment 4 Mike A. Harris 2002-08-07 22:18:54 EDT
Just because you compile something against one release of imap
and it works, and compile it against another release of imap
and it does not work, does not in any way lock it into being a
bug in the imap server or sources.  It is entirely possible that
this software is misusing interfaces, or some interface has
changed that should not have been used by software (such as
internal interfaces).

I've looked into this a bit, and I believe that it is a bug in
the php software, not in UW imap.  Without specific proof of a
bug, and more troubleshooting and debugging information supplied
in the bug report, it isn't worth wasting a lot of time debugging
to find out in the end that I'm right.

Please report this bug to the upstream maintainers of UW imap if you
believe it is a bug in UW imap.  I personally consider it a php webmail
bug however, and suggest you report the problem to the authors of
the php software you're using.



Note You need to log in before you can comment on or make changes to this bug.