Bug 65698 - ppp dies after it almost connects
ppp dies after it almost connects
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-30 08:58 EDT by Need Real Name
Modified: 2007-03-26 23:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-16 12:07:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-30 08:58:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I dial up using kppp, and the dialer connects, reports a speed in the log, then 
disconnects abruptly while I see the process "logging onto network" in the kppp 
screen.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open kppp
2.Dial to my ISP
3.Look in terminal from which kppp was initiated for error message.
	

Actual Results:  The dialer gives the error message in the terminal.

Couldn't find interface ppp0: No such device

Then, I check the log files (tail -f /var/log/messages)and get this.

May 22 03:09:06 linux-firewall modprobe: modprobe: Can't locate module ppp0
May 22 03:09:18 linux-firewall last message repeated 103 times
May 22 03:09:46 linux-firewall pppd[1138]: pppd 2.4.0 started by root, uid 0
May 22 03:09:46 linux-firewall pppd[1138]: Using interface ppp0
May 22 03:09:46 linux-firewall pppd[1138]: Connect: ppp0 <--> /dev/ttyS0
May 22 03:09:46 linux-firewall modprobe: modprobe: Can't locate module net-pf-5
May 22 03:09:47 linux-firewall pppd[1138]: Hangup (SIGHUP)
May 22 03:09:47 linux-firewall pppd[1138]: Modem hangup
May 22 03:09:47 linux-firewall pppd[1138]: Connection terminated.
May 22 03:09:47 linux-firewall pppd[1138]: Exit.





Expected Results:  It should have connected.

Additional info:

Nearly every redhat expert in almost every message board and irc chat group 
(irc.linpeople.org) from the Eastern to the Western seaboard are scratching 
their heads on this one and we don't have a clue how to fix it.

I am using kernel 2.4.9, recently rebuilt in ppp built-in mode and module, 
neither made any difference. Also tried kernel 2.4.2 and 2.4.18, both built-in 
and module and no difference.

Please e-mail me @ ryanoe@yahoo.com when you have solved it. I've been working 
on this for 3 weeks now.
Comment 1 Thomas Woerner 2004-08-16 12:07:15 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.