Bug 65699 - ttmkfdir does not work, aborted
ttmkfdir does not work, aborted
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-30 10:29 EDT by Chad M. Stewaart
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-05 10:05:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chad M. Stewaart 2002-05-30 10:29:06 EDT
Description of Problem:

The binary, ttmkfdir, that is shipped with RHL 7.3 does not work out of the box.
 When one tries to add fonts it returns Aborted.  

I had to download FreeType and the source for ttmkfdir, then compile a new
binary.  The new compiled binary works.


Version-Release number of selected component (if applicable):


How Reproducible:

mkdir /usr/X11R6/lib/X11/fonts/winfonts
cd /usr/X11R6/lib/X11/fonts/winfonts
cp over your ttf fonts
ttmkfdir -o fonts.scale


It will not work.


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Need Real Name 2002-05-30 19:11:28 EDT
Hi! Does this bug also effect OpenOffice if you included ALL language support in
the RedHat Linux installation ?
People in OpenOffice.org also concern a lot about this problem.
Please see Bug ID 4726 in OpenOffice.org
The problem seems to be if you install ALL language support, zh_TW (Traditional
Chinese) will scrull up entire freetype. Even if your OpenOffice 1.0 is the
original English version and you don't even know how to log in linux other than
english, your fonts get very ugly (spacing too much between words). But every
thing just works perfectly out of the box of RedHat7.2 ! 

Please notice, not only chinese version of OpenOffice is affected, but also any
version of OpenOffice literally all got scrulled up!

Really appreciate if any one can have a looke!

John
Comment 2 Ngo Than 2002-06-02 11:32:11 EDT
it's a bug in XFree86, assigned to corrected component
Comment 3 Mike A. Harris 2002-06-04 22:51:13 EDT
As far as I'm concerned, it is not a bug in XFree86.  It's a bug in some
of the font packages that we're shipping and/or in ttmkfdir.

You should not at all need to download a new freetype or compile it.

ttmkfdir is not a part of freetype.  It used to be included in our freetype
package however for lack of a better place to put it.  It is now included
in our XFree86 packaging instead.

Microsoft webfonts do work, however if you copy a full dir of fonts
from Windows into Linux, it may or may not work.  There are certain strict
rules which must be followed in font filenames in X.  No spaces, no
punctuation, and no uppercase letters in the font filenames.  If any
fonts in a dir contain any of those, then things will not work, and it
isn't considered a bug (however it is inconvenient definitely).

Since I use webfonts and many other Truetype fonts and ttmkfdir works
fine for me, there isn't much we can do without more specific information.

One thing you can try to do to narrow the problem down, is to move all
of the fonts out of that directory, then move them one at a time back,
running ttmkfdir each time until it fails.  When it fails, you know
the bad font.  Then it is either just that - a bad font, or it is
a ttmkfdir bug.  Both are equally plausible.
Comment 4 Zing 2002-06-05 09:25:19 EDT
The windows font mtsorts.ttf is the one that failed for me.  Try removing that
if you have it and ttmkfdir should succeed.

microsoft kb article (Q138795):
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q138795
Comment 5 Chad M. Stewaart 2002-06-05 10:05:26 EDT
mharris,

Thank you for your comments.  I suspect that the version of ttmkfdir that I
downloaded and used has this issue resolved.  When I used the new binary I was
able to use it w/o a problem.  Of course makes me wonder what it did when it
found a font it could not deal with, skip it and try next, or simply stop there. :)

The author does not seem fit to use version numbers, ugh.  Here's the cksum of
the files, default and the one I compiled

2116023116 158387 /usr/bin/ttmkfdir
2327428863 31596 /home/dev/ttmkfdir/ttmkfdir

Regards,
Chad
Comment 6 Mike A. Harris 2002-08-07 21:02:18 EDT
As mentioned above the mtsorts.ttf font file is corrupt and buggy.
Closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.