Bug 656998 - M-Audio Fast Track Pro needs special profiles
Summary: M-Audio Fast Track Pro needs special profiles
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pulseaudio
Version: 6.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Wim Taymans
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 520495
Blocks: 645519
TreeView+ depends on / blocked
 
Reported: 2010-11-24 16:50 UTC by Dave Maley
Modified: 2016-05-02 17:16 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Some M-audio fasttrack pro devices, the input device is at index 1 instead of index 0. Consequence: We don't always detect the input device on M-Audio FastTrack Pro devices. As a result, we don't seen the device listed as an input device in the sound preferences. Fix: Add an extra parameter to the profile description to also check the devices at index 1. Result: The capture device is detected and shows up as an available input device in the sound preferences.
Clone Of: 520495
Environment:
Last Closed: 2016-02-03 10:56:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
'pacmd ls' output (25.94 KB, text/plain)
2010-11-24 16:51 UTC, Dave Maley
no flags Details
'alsa-info.sh --no-upload' output (31.39 KB, text/plain)
2010-11-24 16:52 UTC, Dave Maley
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0113 0 normal SHIPPED_LIVE pulseaudio bug fix update 2016-02-03 15:55:17 UTC

Description Dave Maley 2010-11-24 16:50:33 UTC
+++ This bug was initially created as a clone of Bug #520495 +++

Description of problem:
I'm unable to set my FastTrack Pro as the record device used by PulseAudio.  When I go to Sound Preferences (gnome-volume-control) the FastTrack isn't listed as an available input device.  It does appear under the hardware tab as well as under output devices.

For apps which use alsa directly (eg. audacity) the FastTrack is available to select as a recording device, and more importantly works properly when used to record.


Version-Release number of selected component (if applicable):
pulseaudio-0.9.21-13.el6.x86_64


How reproducible:
100%


Steps to Reproduce:
1. connect FastTrack Pro
2. System -> Preferences -> Sound -> Input

  
Actual results:
FastTrack Pro not available to select as input device


Expected results:
FastTrack Pro be listed as available record device


Additional info:

Comment 1 Dave Maley 2010-11-24 16:51:28 UTC
Created attachment 462693 [details]
'pacmd ls' output

Comment 2 Dave Maley 2010-11-24 16:52:02 UTC
Created attachment 462694 [details]
'alsa-info.sh --no-upload' output

Comment 3 Adam Williamson 2010-11-24 18:37:24 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 RHEL Program Management 2011-01-07 15:50:41 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 5 RHEL Program Management 2011-07-06 00:24:30 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 14 errata-xmlrpc 2016-02-03 10:56:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0113.html


Note You need to log in before you can comment on or make changes to this bug.