Bug 657019 - Command line installation of proxy 5.4 fails
Command line installation of proxy 5.4 fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
540
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Stephen Herr
Red Hat Satellite QA List
:
Depends On:
Blocks: sat54-errata 714211
  Show dependency treegraph
 
Reported: 2010-11-24 12:29 EST by Martin Poole
Modified: 2011-06-17 16:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 714211 (view as bug list)
Environment:
Last Closed: 2010-12-03 10:11:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Poole 2010-11-24 12:29:53 EST
Description of problem:

Installation of Proxy 5.4 from a satellite server 5.4 (upgraded from previous version) fails.

# configure-proxy.sh RHN Parent [satellite.example.com]: 
CA Chain [/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT]: 
Proxy version to activate [5.3]: 5.4
Traceback email []: 
Use SSL [Y/n]: 
HTTP Proxy []: 
Regardless of whether you enabled SSL for the connection to the Spacewalk
Parent
Server, you will be prompted to generate an SSL certificate.
This SSL certificate will allow client systems to connect to this Spacewalk
Proxy
securely. Refer to the Spacewalk Proxy Installation Guide for more information.
Organization []: none
Organization Unit [host-139.example.com]: 
Common Name [host-139.example.com]: 
City []: city
State []: state
Country code []: US
Email []: root@host-139.example.com
API version: 5.4.0

There was a problem activating the RHN Proxy entitlement:
ERROR: upon entitlement/activation attempt: unknown error - <Fault 1046:
'redstone.xmlrpc.XmlRpcFault: proxy_channel_not_found'>
Proxy activation failed! Installation interrupted.
API version: 5.4.0
RHN Proxy successfully deactivated.




Version-Release number of selected component (if applicable):

spacewalk-proxy-installer-1.1.2-1.el5sat


Additional info:

satellite server is rhel5.5, x86_64, 5.4 upgrade from 5.3

all proxy channels synced and current.

fresh rhel5.5 install for proxy server.


Would appear to be related to versions being offered by the satellite server.

[root@host-139 ~]# rhn-proxy-activate --server=satellite.example.com --list-available-versions
5.3
5.2


Using the webUI on the satellite and using the deprecated proxy install I can install the 5.4 proxy successfully (modulo osad bug in BZ656963)
Comment 1 Miroslav Suchý 2010-11-25 05:46:12 EST
This is caused by missing mapping between table RHNCHANNEL with labels:
redhat-rhn-proxy-5.4-server-i386-5
redhat-rhn-proxy-5.4-server-x86_64-5
and table RHNCHANNELPRODUCT with product, version:
proxy, 5.4

Interesting is that this mapping exist for
redhat-rhn-proxy-5.4-server-x86_64-6
redhat-rhn-proxy-5.4-server-i386-6
but we do not have this product (yet).

This is hosted problem. RHN Satellite receive this data via satellite-sync.
Please add this missing mappings. You can leave those extraneous data on place, it does not harm anything.

I verified that if I run on RHN Satellite:
update rhnchannel set CHANNEL_PRODUCT_ID=(select id from RHNCHANNELPRODUCT where product='proxy' and version=5.4) where label='redhat-rhn-proxy-5.4-server-x86_64-5' or label='redhat-rhn-proxy-5.4-server-i386-5';
then it will start working.
Comment 5 Clifford Perry 2010-12-01 17:26:33 EST
5.4.0 Satellite - sync'd only with RHN, which has 5.3 and 5.4 Proxy channels on it, I seem to be missing a 5.4 Proxy product from rhnchannelproduct:

SQL> SELECT ID,LABEL,CHANNEL_PRODUCT_ID from rhnChannel WHERE label like 'redhat-rhn-proxy-%';

        ID
----------
LABEL
--------------------------------------------------------------------------------
CHANNEL_PRODUCT_ID
------------------
       102
redhat-rhn-proxy-5.3-server-i386-5
                 1

       103
redhat-rhn-proxy-5.4-server-i386-5


        ID
----------
LABEL
--------------------------------------------------------------------------------
CHANNEL_PRODUCT_ID
------------------


SQL> SELECT * FROM rhnChannelProduct where product like '%oxy%';

        ID
----------
PRODUCT
--------------------------------------------------------------------------------
VERSION                                                          B CREATED
---------------------------------------------------------------- - ---------
MODIFIED
---------
         1
proxy
5.3                                                              N 23-NOV-10
23-NOV-10


SQL>
Comment 17 Martin Poole 2010-12-03 10:01:20 EST
Customer reports 

# rhn-proxy-activate --server=satellite.example.com --list-available-versions
5.4
5.3


and is proceeding with other checks, but this part seems resolved.
Comment 18 Stephen Herr 2010-12-03 10:11:15 EST
Fantastic. I will close this bug then.

Note You need to log in before you can comment on or make changes to this bug.