Bug 65706 - RFE: place USB audio devices *after* fixed ones
RFE: place USB audio devices *after* fixed ones
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2002-05-30 12:08 EDT by Craig Paterson
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-12-16 20:09:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Craig Paterson 2002-05-30 12:08:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461; Q312461)

Description of problem:
Turtle Beach Santa Cruz soundcard detected fine by sndconfig, but no output. 
Changing mixer settings has no effect. Attempting to play back an MP3 in xmms, 
xmms "zooms through" the file in a few seconds, but with no output. Card worked 
fine in RH 7.2, has not worked since upgrade.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install Red Hat 7.2
2. Setup sound with sndconfig
3. Upgrade to 7.3

Actual Results:  - No audible output from sound card
- Only one channel shown in aumix and other mixer applications
- Altering levels on this single channel has no effect
- XMMS runs and doesn't report errors, but runs through the file at highly 
increased speed, and there is no sound
- sndconfig (apaprently) detects the card correctly, but there is no output

Expected Results:  Normal playback

Additional info:

lspci -v gives this entry for the sound card:

00:0a.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24 [CrystalClear
SoundFusion Audio Accelerator] (rev 01)
	Subsystem: Voyetra Technologies: Unknown device 3357
	Flags: bus master, slow devsel, latency 32, IRQ 15
	Memory at d5800000 (32-bit, non-prefetchable) [size=4K]
	Memory at d5000000 (32-bit, non-prefetchable) [size=1M]
	Capabilities: [40] Power Management version 

my /etc/modules.conf looks like this

alias eth0 eepro100
alias parport_lowlevel parport_pc
alias usb-controller usb-uhci
alias scsi_hostadapter aic7xxx
#alias scd1 sr_mod
#pre-install sg modprobe ide-scsi
#pre-install sr_mod modprobe ide-scsi
#pre-install ide-scsi modprobe ide-cd
alias sound-slot-0 cs46xx
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
|| :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1
|| :
Comment 1 Michael Fulbright 2002-06-04 11:09:36 EDT
Reassigning to kudzu.
Comment 2 Bill Nottingham 2002-06-04 11:35:12 EDT
If xmms 'zips through' the file, it's probably using the disk writer plugin -
look for large files in your home directory. ;)

As for the card, are there any errors in 'dmesg' when you load the module?
Comment 3 Arjan van de Ven 2002-06-04 11:38:01 EDT
Are you using KDE (and hence the artsd plugin)?
I've seen this happen with the 7.3 artsd with a totally different card before
Comment 4 Craig Paterson 2002-06-04 13:14:08 EDT
It didn't seem to be the disk writer plugin -- it was selected in root's xmms
preferences, but not my user prefs. Toggling it on and off causes WAV files to
be written (or not) as expected. But with OSS selected as the output target,
xmms still "zooms through" the file.

I'm not using KDE --  WindowMaker 0.80, source compile.

There is nothing at all in dmesg about loading the module, as far as I can tell.
But trying to load it at the command line, I get an unresolved symbol error:

[root@pegasus root]# /sbin/insmod cs46xx
Using /lib/modules/2.4.18-3/kernel/drivers/sound/cs46xx.o
/lib/modules/2.4.18-3/kernel/drivers/sound/cs46xx.o: unresolved symbol

Browsing dmesg output I notice that it's picking up my Logitech Quickcam and
installing a driver for it (as far I recall, 7.2 didn't). The Quickcam has an
inbuilt microphone, and I'm guessing it's this channel that's showing up when I
run xmixer (as I'm offered a single microphone input to adjust). Any known
issues with multiple audio sources? (Though I'm guessing the unresolved symbol
error is a hotter lead.)
Comment 5 Arjan van de Ven 2002-06-04 14:23:10 EDT
The logitech quickam claims to the OS to be speakers as well and yes I've seen
this becoming the first audio device as a result. XMMS has an option to select
which device to use, using /dev/dsp1 instead of /dev/dsp will work I suspect.
(It did for a friend of mine ;)
Comment 6 Arjan van de Ven 2002-06-04 14:24:04 EDT
(oh and the unresolved symbol most likely comes from using insmod and not
modprobe. modprobe will do the same thing as insmod with the exception that it
also resolves dependencies first, eg it'll load the ac97 module first)
Comment 7 Craig Paterson 2002-06-10 14:24:53 EDT
Spot on, chaps.

My soundcard had indeed been moved to


in favour of the QuickCam. Of course, if I wanted to squirm I'd say, "The
installer should have spotted that," but I won't, because I really think I
should have spotted it.


Note You need to log in before you can comment on or make changes to this bug.