Bug 657119 - /dev/cciss does not exist, rendering cciss_vol_status useless
Summary: /dev/cciss does not exist, rendering cciss_vol_status useless
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cciss_vol_status
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Joshua Roys
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-24 23:57 UTC by Benny Amorsen
Modified: 2010-12-01 10:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-01 10:38:44 UTC


Attachments (Terms of Use)
lspci for the affected server (3.74 KB, text/plain)
2010-11-30 11:10 UTC, Benny Amorsen
no flags Details
lsmod for the affected server (1.07 KB, text/plain)
2010-11-30 11:11 UTC, Benny Amorsen
no flags Details

Description Benny Amorsen 2010-11-24 23:57:24 UTC
Description of problem:
cciss_vol_status relies on the presence of the /dev/cciss directory and its contents. In Fedora 14, at least as of kernel-2.6.35.6-48.fc14.x86_64, cciss drives are presented like any other disk as /dev/sda and so forth, and the /dev/cciss directory does not exist.

This unfortunately makes cciss_vol_status unable to work:

cciss_vol_status /dev/cciss/c0d0
cciss_vol_status: open /dev/cciss/c0d0: No such file or directory

Version-Release number of selected component (if applicable):
cciss_vol_status-1.06-2.fc13.x86_64

How reproducible:
Every time

The appropriate action might simply be retiring the package, but it would be nice to have a replacement.

Comment 1 Joshua Roys 2010-11-30 01:08:41 UTC
Hello,

Could you please attach the output (as root) of `lspci -nn` and dmesg?

Thanks.

Josh

Comment 2 Benny Amorsen 2010-11-30 11:10:06 UTC
Created attachment 463692 [details]
lspci for the affected server

We can possibly arrange ssh access to a machine affected by this bug, if you are interested.

Comment 3 Benny Amorsen 2010-11-30 11:11:13 UTC
Created attachment 463693 [details]
lsmod for the affected server

Comment 4 Joshua Roys 2010-11-30 14:11:53 UTC
Ah, it looks like `hpsa' is a new driver that is replacing cciss.  See http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob;f=Documentation/scsi/hpsa.txt;h=dca658362cbf2fcf0be361d0c99ce9a1fd1f4055;hb=HEAD for more details.

`man cciss_vol_status' seems to indicate that running `cciss_vol_status /dev/sgX' should work...  They also have a section describing procedures that should identify which sg device to examine.

Hopefully that will work for you!

Comment 5 Benny Amorsen 2010-12-01 10:38:27 UTC
You are right:

# cciss_vol_status /dev/sg0
/dev/sda: (Smart Array P410i) RAID 1 Volume 0 status: OK. 

Thank you and sorry for the false alarm.


Note You need to log in before you can comment on or make changes to this bug.