This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 657128 - kde-plasma-networkmanagement applet does not connect to hidden networks
kde-plasma-networkmanagement applet does not connect to hidden networks
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-plasma-networkmanagement (Show other bugs)
16
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-24 19:50 EST by vitor.dominor
Modified: 2012-06-21 19:10 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 19:10:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 209464 None None None 2012-06-20 09:37:28 EDT

  None (edit)
Description vitor.dominor 2010-11-24 19:50:12 EST
Description of problem:
The kde networkmanagement applet does not allow connecting to hidden networks. It's widely known networkmanager does not connect to hidden networks by default. Even the gnome doesn't do that automatically. Instead, there is an explicit option to connect to hidden networks, in which we supply the SSID and network configuration.
A recent build of this applet also seems to have that option. Apparently, when you select a wireless network interface on the left panel, besides the known wireless networks (not hidden?) in the right panel, there a blank text field to input the SSID of the hidden network and press enter to proceed. However, several times I have tried to do that and nothing happens. No other network is detected nor any additional configuration is asked for.

Version-Release number of selected component (if applicable):
0.9-0.28-20101011.fc14

How reproducible:
Always

Steps to Reproduce:
1. Select wireless network interface, on the left panel.
2. Input SSID of hidden network, in the text field, on the right panel.
3. Press Enter.
  
Actual results:
Nothing happens.

Expected results:
Ask for additional information or detect hidden network.

Additional info:
The tested hidden networks are detected and quickly connected to, in the gnome frontend.
Comment 1 vcato1701 2010-12-11 22:11:33 EST
I'm seeing the same issue.  If I use nm-applet instead, I can get a connection.  If I use the kde networkmanager applet I haven't found any way to connect to the hidden network, but I can connect from the command line using 

nmcli con up id <network name>
Comment 3 collura 2011-09-06 11:27:02 EDT
still seems to be case with f15kde and f16kde-alpha-livecd

ps: good link from comment2
Comment 4 Rex Dieter 2012-01-11 09:22:10 EST
I think this is still valid (heard rumors, not able to test myself), bumping to f16 for now.  need to track down an upstream bug to link this to (or file a new one too).
Comment 5 Kevin Kofler 2012-01-11 10:24:01 EST
Upstream claims this has been fixed eons ago. If this is still broken, it needs to be reported upstream.
Comment 6 Martin Bříza 2012-06-20 09:37:28 EDT
As Rex wrote, upstream claims this bug to be fixed (see the external tracker) Unfortunately, I can't test the behavior either, so please, if anyone has this kind of problem, unset the needinfo flag and give as much information as you can. 
Thank you.
Comment 7 Kevin Kofler 2012-06-21 19:10:16 EDT
No confirmation newer than 2011-09-06 that this still happens. Upstream reports it as fixed. It was originally claimed fixed on 2011-09-09, but an additional fix was applied on 2012-02-04.

Note that this is only fixed in Fedora 15 and newer. The report was originally against Fedora 14, which is no longer supported, and which used an old branch of kde-plasma-networkmanagement (based on the old NetworkManager 0.8) which did not get the fix for this bug.

Note You need to log in before you can comment on or make changes to this bug.