Bug 65714 - aspell Segmentation fault checking TeX document ending in a comment with no newline
aspell Segmentation fault checking TeX document ending in a comment with no n...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: aspell (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-30 13:57 EDT by peskin
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-30 13:57:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description peskin 2002-05-30 13:57:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9-31 i686)

Description of problem:
Whenever I try to use aspell to check a TeX or LaTeX document that
ends in a comment with no newline, aspell crashes with "Segmentation fault".

Version-Release number of selected component (if applicable):
0.32.6-2

How reproducible:
Always

Steps to Reproduce:
echo -n "%" | aspell -l -t


Actual Results:  Segmentation fault

Expected Results: aspell should have listed any misspelled words (in
the above test case, there are none), and then exited normally.

Additional info:

I am using aspell-0.32.6-2 on 
Red Hat Linux release 7.1 (Seawolf)
Linux ming.ece.utah.edu 2.4.9-31 #1 Tue Feb 26 07:11:02 EST 2002 i686 unknown
Comment 1 Trond Eivind Glomsrxd 2002-07-08 18:39:10 EDT
Can't reproduce this with aspell-0.33.7.1, it seems fixed now.

Note You need to log in before you can comment on or make changes to this bug.