This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 657182 - qemu-kvm process exited during resume from s4
qemu-kvm process exited during resume from s4
Status: CLOSED DUPLICATE of bug 516769
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
i686 Linux
medium Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-11-25 01:27 EST by Chao Yang
Modified: 2010-12-01 03:42 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-01 03:42:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kernel console output (1.84 KB, text/plain)
2010-11-25 01:32 EST, Chao Yang
no flags Details

  None (edit)
Description Chao Yang 2010-11-25 01:27:15 EST
Description of problem:


Version-Release number of selected component (if applicable):

--Host
# rpm -qa|grep kvm
kmod-kvm-83-215.el5
kmod-kvm-debug-83-215.el5
kvm-qemu-img-83-215.el5
kvm-tools-83-215.el5
etherboot-zroms-kvm-5.4.4-13.el5
kvm-debuginfo-83-215.el5
kvm-83-215.el5

# uname -r
2.6.18-232.el5

--Guest

# uname -r
2.6.32-71.el6.i686


How reproducible:


Steps to Reproduce:
1.boot a guest
# /usr/libexec/qemu-kvm -no-hpet -rtc-td-hack -usbdevice tablet -startdate now -name rhel6.0-32 -smp 2 -m 4G -boot c  -drive file=/root/zhangjunyi/rhel6_32.qcow2,media=disk,if=virtio,cache=none,format=qcow2,werror=stop,boot=on -vnc :18  -cpu qemu64 -M rhel5.6.0 -notify all -balloon none -monitor stdio -net none
2. connect to guest with vnc
# vncviewer 10.66.72.60:18

3. suspend to disk
# echo disk > /sys/power/state
  
Actual results:
qemu-kvm process got killed during resume from s4

Expected results:

qemu-kvm process exists during resume from s4
Additional info:

1. I tried with -pcidevice and without -pcidevice, both hit this issue.
2. qemu-kvm exited with message: guest moved used index from 73534 to 0
3. attached screenshot and kernel message during resume
Comment 1 Chao Yang 2010-11-25 01:32:21 EST
Created attachment 462829 [details]
kernel console output

During resume from s4, I sometimes can see the login hins, but it exited soon
Comment 2 Chao Yang 2010-11-25 03:38:03 EST
It did't hit this issue with ide interface
Comment 3 Don Dutile 2010-11-30 16:59:26 EST
A similar bz for rhel6 occurred -- virtio-blk does not support s4 correctly.
Not even sure it'll be in rhel6.1; so rhel5.x is in the same boat.
Added Kevin Wolf to cc: to confirm.
Comment 4 Kevin Wolf 2010-12-01 03:42:57 EST
Correct. There was another bug for it and it was decided that a possible future support for suspend/resume won't be backported to RHEL 5. I'm not sure if there's one open for RHEL 6, but Amit was working on it upstream.

*** This bug has been marked as a duplicate of bug 516769 ***

Note You need to log in before you can comment on or make changes to this bug.