Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 657183 - KDE Workspace Name doesn't persist the changed name after logoff and login. [NEEDINFO]
Summary: KDE Workspace Name doesn't persist the changed name after logoff and login.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kdebase
Version: 5.4
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Than Ngo
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 743405
TreeView+ depends on / blocked
 
Reported: 2010-11-25 06:28 UTC by Fabio Dias da Cunha
Modified: 2018-11-14 16:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:06:56 UTC
Target Upstream Version:
pm-rhel: needinfo? (fdacunha)


Attachments (Terms of Use)
Proposed patch (513 bytes, patch)
2010-11-25 16:08 UTC, Olivier Fourdan
no flags Details | Diff

Description Fabio Dias da Cunha 2010-11-25 06:28:14 UTC
Description of problem:

KDE Workspace Name doesn't persist the changed name after logoff and login.
Red Hat Enterprise Linux 5.4 Server
KDE kdesdk-3.5.4-3
Using 2 monitors for this test gave me the same result.

Version-Release number of selected component (if applicable):

How reproducible:

4 screen layout, separate X screen (Eg: Not panorama) Individual

When changing the name of the virtual desktops, it changes correctly on the screen but does not update the ~/"user"/.kde/share/config/kwinrc file correctly. So upon logging out and in the changes are lost except for a random amount of screens.

For instance: Upon logging out 1 of the 4 screens may save the changes and therefore keep them on login, however the other 3 screens will not.

Steps to Reproduce:
1. Using 2 monitors (individual option, not spanning)
2. On monitor 1 change the workspace name using "Configure Desktop" option (GUI)
3. On monitor 2 change the workspace name using "Configure Desktop" option (GUI)
4. Logoff
5. Login
  
Actual results:
Workspace doesn't persist the changed name as desired.  

Expected results:
Using Configure Desktop from GUI keep their names when changed after logoff.

Additional info:
Manually changing this file produces the desired results, however when then attempting to further change this file via the kde desktop settings control panel, the previous behaviour is continued. Where one of the four screen layouts will save correctly, and the other 3 will remain unchanged.

Comment 1 Olivier Fourdan 2010-11-25 16:08:59 UTC
Created attachment 462934 [details]
Proposed patch

KDE is able to have different desktop names per screen, the default screen use the config entry [Desktops] whereas other screens will use [Desktops-screen-n] (where n is the screen number > 0)

Unfortunately, the config is not saved on disk once the DesktopNames is received, thus causing the issue reported here.

Workspace::netCheck() in kwin/events.cpp is called once the property is changed on the root window and Workspace::saveDesktopSettings() does updates the entries yet the file on disk is not updated.

Calling sync() at the end of saveDesktopSettings() fixes that, hence the proposed patch.

Comment 8 RHEL Program Management 2012-06-12 01:14:06 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 9 RHEL Program Management 2014-03-07 12:17:29 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in the  last planned RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX. To request that Red Hat re-consider this request, please re-open the bugzilla via  appropriate support channels and provide additional business and/or technical details about its importance to you.

Comment 10 RHEL Program Management 2014-06-02 13:06:56 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.