Bug 657243 - no response for some key on Win2008r2 guest
no response for some key on Win2008r2 guest
Status: CLOSED DUPLICATE of bug 643317
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-11-25 05:12 EST by Suqin Huang
Modified: 2013-01-09 18:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-02 03:27:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2010-11-25 05:12:05 EST
Description of problem:
boot guest with the following cmd, press Ctrl+Alt+Delete, and input passwd, Ctrl+Alt+Delete can be invoked, but can not input passwd.

Version-Release number of selected component (if applicable):
kvm-83-213.el5

How reproducible:
sometime

Steps to Reproduce:
1. cmd
/usr/libexec/qemu-kvm -drive file=/usr/Auto/autotest/client/tests/kvm/images/win2008r2-64-virtio.qcow2,index=0,if=virtio,media=disk,cache=none,format=qcow2,boot=on -net nic,vlan=0,model=virtio,macaddr=9a:2d:20:42:2a:60 -net tap,vlan=0,ifname=t0-140400-SfXj,script=/usr/Auto/autotest/client/tests/kvm/scripts/qemu-ifup-switch,downscript=no -m 2048 -smp 2,cores=1,threads=1,sockets=2 -cpu qemu64,+sse2,+sse4.2,+sse4.1 -vnc :0  -rtc-td-hack -M rhel5.5.0 -usbdevice tablet -boot c -monitor stdio

2.
3.
  
Actual results:


Expected results:


Additional info:
1. issue don't exist when boot guest without +sse4.2,+sse4.1
2. host info:
2.6.18-232.el5

processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 26
model name	: Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping	: 4
cpu MHz		: 1600.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 3
cpu cores	: 4
apicid		: 7
fpu		: yes
fpu_exception	: yes
cpuid level	: 11
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx rdtscp lm constant_tsc ida nonstop_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr sse4_1 sse4_2 popcnt lahf_lm

3. guest
Window2008R2
Comment 1 Suqin Huang 2010-11-26 03:14:06 EST
I can reproduce with the following cmd: (without sse4.1, sse4.2)

/usr/libexec/qemu-kvm -drive file=/root/win2008r2-64-virtio.bak,index=0,if=virtio,media=disk,cache=none,format=qcow2,boot=on -net nic,vlan=0,model=virtio,macaddr=9a:2d:20:42:2a:60 -net tap,vlan=0,ifname=t0-140400-SfXj,script=/usr/Auto/autotest/client/tests/kvm/scripts/qemu-ifup-switch,downscript=no -m 2048 -smp 2,cores=1,threads=1,sockets=2 -cpu qemu64,+sse2 -vnc :0  -rtc-td-hack -M rhel5.6.0 -usbdevice tablet -boot c -monitor stdio -drive file=/root/storage.qcow2,index=1,media=disk
Comment 2 Gerd Hoffmann 2010-11-29 04:26:14 EST
Which vnc client you are using?
Comment 3 Suqin Huang 2010-11-29 21:51:59 EST
vnc-4.1.2-14.el5_3.1
tigervnc-1.0.1-3.fc12.i686
Comment 4 Gerd Hoffmann 2010-11-30 04:25:43 EST
How do you send Ctrl-Alt-Del?  Using the F8 menu?

In case windows doesn't accept the password:
Does it help to press the left Ctrl key once?
Does it help to press the left Alt key once?
Comment 5 Gerd Hoffmann 2010-11-30 04:26:39 EST
Is possibly a duplicate of bug #643317
Comment 6 Gerd Hoffmann 2010-12-01 03:11:32 EST
Can you test whenever kvm-83-218.el5 fixes the bug please?
Comment 7 Suqin Huang 2010-12-02 01:28:42 EST
1. reproduce in kvm-83-213.el5
keyboard work after pressing the left Ctrl key once.
keyboard doesn't work after pressing the left Alt key once.

Ctrl+Alt+Delete is sent by F8 menu in bug #643317, Ctrl+Alt+Delete is sent by kerboard in this bug. they are not duplicate.

2. Can not reproduce in kvm-83-218.el5
Comment 8 Gerd Hoffmann 2010-12-02 03:27:27 EST

*** This bug has been marked as a duplicate of bug 643317 ***

Note You need to log in before you can comment on or make changes to this bug.