Bug 657274 - perl-GSSAPI rebuild fails with mock and rpmbuild, x86_64, perl-GSSAPI-0.26-5.el6
Summary: perl-GSSAPI rebuild fails with mock and rpmbuild, x86_64, perl-GSSAPI-0.26-5.el6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-GSSAPI
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Petr Pisar
QA Contact: Karel Srot
URL:
Whiteboard:
: 661796 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-25 11:09 UTC by Sergio Rubio
Modified: 2013-01-15 06:57 UTC (History)
4 users (show)

Fixed In Version: perl-GSSAPI-0.26-6.el6
Doc Type: Bug Fix
Doc Text:
Cause: Rebuilding perl-GSSAPI package. Consequence: The package cannot be built because the spec file utilizes file which has been removed from krb5-devel package. Fix: The spec file has been adjusted to current krb5-devel files. Result: perl-GSSAPI can be built against current krb5-devel in RHEL-6 environment now.
Clone Of:
Environment:
Last Closed: 2012-10-04 12:21:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fix from Fedora (1.40 KB, patch)
2010-11-25 12:13 UTC, Petr Pisar
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1340 normal SHIPPED_LIVE perl-GSSAPI bug fix update 2012-10-04 16:15:02 UTC

Description Sergio Rubio 2010-11-25 11:09:12 UTC
Description of problem:
+ . /etc/profile.d/krb5-devel.sh
/var/tmp/rpm-tmp.6qJsU5: line 32: /etc/profile.d/krb5-devel.sh: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.6qJsU5 (%build)

Version-Release number of selected component (if applicable):
perl-GSSAPI-0.26-5

How reproducible:
Always 

Steps to Reproduce:
try to rebuild with mock or rpmbuild
  
Actual results:
fails

Expected results:
fails

Additional info:

Comment 2 Petr Pisar 2010-11-25 12:11:42 UTC
This package has been compiled before krb5-devel update making /etc/profile.d/krb5-devel.sh obsolete. This flaw will be fixed once perl-GSSAPI package recompilation will be required.

Comment 3 Petr Pisar 2010-11-25 12:13:58 UTC
Created attachment 462879 [details]
Fix from Fedora

Comment 4 Petr Pisar 2010-12-09 17:14:55 UTC
*** Bug 661796 has been marked as a duplicate of this bug. ***

Comment 16 errata-xmlrpc 2012-10-04 12:21:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1340.html


Note You need to log in before you can comment on or make changes to this bug.