Bug 657302 - AS4 plugin: provide session metrics for clustered wars
AS4 plugin: provide session metrics for clustered wars
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.0.0
Unspecified Unspecified
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On: jon30-bugs
Blocks: 674531
  Show dependency treegraph
 
Reported: 2010-11-25 07:34 EST by Heiko W. Rupp
Modified: 2014-06-30 16:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 674531 (view as bug list)
Environment:
Last Closed: 2014-06-30 16:33:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ear file with <distributed/> tag in the web.xml (1.04 KB, application/octet-stream)
2011-01-27 06:50 EST, Heiko W. Rupp
no flags Details
war file with distributed tag (907 bytes, application/octet-stream)
2011-01-27 06:56 EST, Heiko W. Rupp
no flags Details

  None (edit)
Description Heiko W. Rupp 2010-11-25 07:34:59 EST
When war files are clustered, the session metrics come from a different MBean than in the non-clustered case.
With the current code, only the non-clustered Mbean is honored and for the clustered case NaN is returned form the plugin, resulting in no data in the UI.
Comment 1 Heiko W. Rupp 2010-11-25 07:37:37 EST
A first solution has been committed in 1239025
Comment 6 Heiko W. Rupp 2011-01-27 06:50:48 EST
Created attachment 475586 [details]
ear file with <distributed/> tag in the web.xml

The attached ear file can be used to test this

THis shows up in jmx-console as 
jboss.web:WebModule=//localhost/test-ear,service=ClusterManager
Comment 8 Heiko W. Rupp 2011-01-27 06:56:01 EST
Created attachment 475587 [details]
war file with distributed tag

This war file can be used for testing . Needs to be deployed in a cluster-config (e.g. production or all)
Comment 10 Charles Crouch 2011-02-22 15:29:27 EST
This just needs to be fixed in master
Comment 12 Jay Shaughnessy 2014-06-30 16:33:11 EDT
This seems to be done

Note You need to log in before you can comment on or make changes to this bug.