Bug 657368 - [abrt] anjuta-1:2.31.90.0-1.fc14: symbol_db_activate: Process /usr/bin/anjuta was killed by signal 6 (SIGABRT)
[abrt] anjuta-1:2.31.90.0-1.fc14: symbol_db_activate: Process /usr/bin/anjuta...
Status: CLOSED DUPLICATE of bug 658471
Product: Fedora
Classification: Fedora
Component: anjuta (Show other bugs)
14
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
abrt_hash:4016177135cd5e84a5b865fedcf...
:
: 668309 678736 709135 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-25 10:58 EST by Gregor Hlawacek
Modified: 2011-05-31 03:39 EDT (History)
32 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-13 11:30:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (17.14 KB, text/plain)
2010-11-25 10:58 EST, Gregor Hlawacek
no flags Details

  None (edit)
Description Gregor Hlawacek 2010-11-25 10:58:05 EST
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: anjuta
component: anjuta
crash_function: symbol_db_activate
executable: /usr/bin/anjuta
kernel: 2.6.35.6-48.fc14.x86_64
package: anjuta-1:2.31.90.0-1.fc14
rating: 4
reason: Process /usr/bin/anjuta was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1290700548
uid: 500

comment
-----
It worked before but now stopped this is the commandline output:

** (anjuta:12157): WARNING **: Can't find libsqlite3.so file.

(anjuta:12157): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(anjuta:12157): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

** (anjuta:12157): WARNING **: Can't find libsqlite3.so file.

(anjuta:12157): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

** (anjuta:12157): WARNING **: Can't find libsqlite3.so file.

(anjuta:12157): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(anjuta:12157): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

** (anjuta:12157): CRITICAL **: gda_server_provider_supports_feature: assertion `GDA_IS_SERVER_PROVIDER (provider)' failed

** (anjuta:12157): WARNING **: Can't find libsqlite3.so file.

(anjuta:12157): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(anjuta:12157): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

(anjuta:12157): libanjuta-symbol-db-WARNING **: Could not open connection to DB_DIR=/home/lawa/.cache/anjuta;DB_NAME=.anjuta_sym_db


libanjuta-symbol-db-ERROR **: Opening global project under /home/lawa/.cache/anjuta
aborting...
Aborted (core dumped)

How to reproduce
-----
1. Start anjuta
2. 
3.
Comment 1 Gregor Hlawacek 2010-11-25 10:58:08 EST
Created attachment 462929 [details]
File: backtrace
Comment 2 Laurent Weislo 2010-11-25 12:24:11 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Starting the software
2.
3.


Comment
-----
Just starting the software, it worked yesterday.
Comment 3 Philip Chimento 2010-11-25 17:41:46 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Start Anjuta.

If done from a terminal, the following is printed:

** (anjuta:2921): WARNING **: Can't find libsqlite3.so file.

(anjuta:2921): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(anjuta:2921): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

** (anjuta:2921): WARNING **: Can't find libsqlite3.so file.

(anjuta:2921): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

** (anjuta:2921): WARNING **: Can't find libsqlite3.so file.

(anjuta:2921): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(anjuta:2921): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

** (anjuta:2921): CRITICAL **: gda_server_provider_supports_feature: assertion `GDA_IS_SERVER_PROVIDER (provider)' failed

** (anjuta:2921): WARNING **: Can't find libsqlite3.so file.

(anjuta:2921): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(anjuta:2921): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

(anjuta:2921): libanjuta-symbol-db-WARNING **: Could not open connection to DB_DIR=/home/fliep/.cache/anjuta;DB_NAME=.anjuta_sym_db


libanjuta-symbol-db-ERROR **: Opening global project under /home/fliep/.cache/anjuta
aborting...
Aborted (core dumped)

Comment
-----
This has only started happening today; yesterday, Anjuta worked perfectly. 

There was a suggestion on the Anjuta mailing list to reinstall libgda, but that didn't fix the problem. Also, the only package that provides libsqlite3.so is xulrunner - I tried reinstalling that too, but it didn't fix the problem either.

I suspect it's a problem with the new libgda 4.2.0-1.fc14, since it seems that I updated it this morning, looking at my yum logs. Here's a list of everything I updated this morning:

Nov 25 09:05:48 Updated: pulseaudio-libs-0.9.21-7.fc14.i686
Nov 25 09:05:50 Updated: libudev-161-7.fc14.i686
Nov 25 09:05:53 Updated: udev-161-7.fc14.i686
Nov 25 09:05:55 Updated: pulseaudio-0.9.21-7.fc14.i686
Nov 25 09:06:01 Updated: vlc-core-1.1.5-1.fc14.i686
Nov 25 09:06:03 Updated: pulseaudio-utils-0.9.21-7.fc14.i686
Nov 25 09:06:05 Updated: 1:libgda-4.2.0-1.fc14.i686
Nov 25 09:06:07 Updated: dracut-006-5.fc14.noarch
Nov 25 09:06:07 Updated: pulseaudio-gdm-hooks-0.9.21-7.fc14.i686
Nov 25 09:06:08 Updated: 1:libgda-sqlite-4.2.0-1.fc14.i686
Nov 25 09:06:09 Updated: pulseaudio-module-x11-0.9.21-7.fc14.i686
Nov 25 09:06:12 Updated: vlc-1.1.5-1.fc14.i686
Nov 25 09:06:13 Updated: pulseaudio-module-gconf-0.9.21-7.fc14.i686
Nov 25 09:06:14 Updated: pulseaudio-module-bluetooth-0.9.21-7.fc14.i686
Nov 25 09:06:15 Updated: libgudev1-161-7.fc14.i686
Nov 25 09:06:16 Updated: pulseaudio-libs-glib2-0.9.21-7.fc14.i686
Nov 25 09:06:17 Updated: nspluginwrapper-1.3.0-15.fc14.i686
Comment 4 Jean Gobin 2010-11-26 09:35:46 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Tried to start Anjuta from Applications->Programming menu



Comment
-----
From the CLI, 

** (anjuta:6850): WARNING **: Can't find libsqlite3.so file.

(anjuta:6850): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(anjuta:6850): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

** (anjuta:6850): WARNING **: Can't find libsqlite3.so file.

(anjuta:6850): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

** (anjuta:6850): WARNING **: Can't find libsqlite3.so file.

(anjuta:6850): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(anjuta:6850): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

** (anjuta:6850): CRITICAL **: gda_server_provider_supports_feature: assertion `GDA_IS_SERVER_PROVIDER (provider)' failed

** (anjuta:6850): WARNING **: Can't find libsqlite3.so file.

(anjuta:6850): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(anjuta:6850): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

(anjuta:6850): libanjuta-symbol-db-WARNING **: Could not open connection to DB_DIR=/home/jeff/.cache/anjuta;DB_NAME=.anjuta_sym_db


libanjuta-symbol-db-ERROR **: Opening global project under /home/jeff/.cache/anjuta



==> Installs the package for sqlite3 devel

Dependencies Resolved

=============================================================================================================================================================================================================================================
 Package                                                    Arch                                                 Version                                                          Repository                                            Size
=============================================================================================================================================================================================================================================
Installing:
 libsq3-devel                                               x86_64                                               20071018-9.fc14                                                  fedora                                               108 k
Installing for dependencies:
 libsq3                                                     x86_64                                               20071018-9.fc14                                                  fedora                                                34 k
 sqlite-devel                                               x86_64                                               3.6.23.1-1.fc14                                                  fedora                                                82 k

Transaction Summary
=============================================================================================================================================================================================================================================
Install       3 Package(s)

Total download size: 224 k
Installed size: 1.2 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Package(s) data still to download: 224 k
(1/3): libsq3-20071018-9.fc14.x86_64.rpm                                                                                                                                                                              |  34 kB     00:00     
(2/3): libsq3-devel-20071018-9.fc14.x86_64.rpm                                                                                                                                                                        | 108 kB     00:00     
(3/3): sqlite-devel-3.6.23.1-1.fc14.x86_64.rpm                                                                                                                                                                        |  82 kB     00:00     
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                                        161 kB/s | 224 kB     00:01     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : libsq3-20071018-9.fc14.x86_64                                                                                                                                                                                         1/3 
  Installing     : sqlite-devel-3.6.23.1-1.fc14.x86_64                                                                                                                                                                                   2/3 
  Installing     : libsq3-devel-20071018-9.fc14.x86_64                                                                                                                                                                                   3/3 

Installed:
  libsq3-devel.x86_64 0:20071018-9.fc14                                                                                                                                                                                                      

Dependency Installed:
  libsq3.x86_64 0:20071018-9.fc14                                                                                    sqlite-devel.x86_64 0:3.6.23.1-1.fc14                                                                                   


==> still the same issue

libsqlite3.so.0.8.6 is present on the system:

[root@jeff-ubuntu lib64]# find . -name "*sql*"
./redland/librdf_storage_sqlite.so
./seed/libseed_sqlite.so
./libsqlite3.so.0
./qt4/plugins/sqldrivers
./qt4/plugins/sqldrivers/libqsqlite.so
./qt4/plugins/script/libqtscript_sql.so.1
./qt4/plugins/script/libqtscript_sql.so
./qt4/plugins/script/libqtscript_sql.so.1.0.0
./qt4/plugins/script/libqtscript_sql.so.1.0
./openoffice.org/basis3.3/share/config/soffice.cfg/modules/dbquery/toolbar/sqlobjectbar.xml
./openoffice.org/basis3.3/program/libmysqllx.so
./libsqlite3.so
./libgda-4.0/providers/libgda-sqlite.so
./xulrunner-1.9.2/libsqlite3.so
./python2.7/site-packages/sqlitecachec.pyc
./python2.7/site-packages/sqlitecachec.pyo
./python2.7/site-packages/sqlitecachec.py
./python2.7/site-packages/_sqlitecache.so
./python2.7/lib-dynload/_sqlite3.so
./python2.7/sqlite3
./pkgconfig/sqlite3.pc
./libsqlite3.so.0.8.6

ldconfig knows about it:

[root@jeff-ubuntu lib64]# ldconfig -p | grep sql
	libsqlite3.so.0 (libc6,x86-64) => /usr/lib64/libsqlite3.so.0
	libsqlite3.so (libc6,x86-64) => /usr/lib64/xulrunner-1.9.2/libsqlite3.so
[root@jeff-ubuntu lib64]# file libsqlite3.so.0
libsqlite3.so.0: symbolic link to `libsqlite3.so.0.8.6'
[root@jeff-ubuntu lib64]# 


Setting LD_LIBRARY_PATH works the issue around.

[jeff@jeff-ubuntu cuda]$ export LD_LIBRARY_PATH=/lib:/usr/lib:/usr/lib64

==> anjuta runs from the CLI
Comment 5 Majdak Aleksandar 2010-11-26 18:55:03 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Start anjuta IDE
2. crash
3.


Comment
-----
Just start anjuta IDE
Comment 6 Jean Gobin 2010-11-26 19:09:02 EST
Additional info concerning this.


Using strace:

stat("libsqlite3", 0x7fff95eaf1c0)      = -1 ENOENT (No such file or directory)
stat("libsqlite3.so", 0x7fff95eaf1c0)   = -1 ENOENT (No such file or directory)
stat("libsqlite3.la", 0x7fff95eaf1c0)   = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 18
fstat(18, {st_mode=S_IFREG|0644, st_size=90461, ...}) = 0
mmap(NULL, 90461, PROT_READ, MAP_PRIVATE, 18, 0) = 0x7f0d10118000
close(18)                               = 0
open("/usr/lib64/xulrunner-1.9.2/libsqlite3.so", O_RDONLY) = 18
read(18, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0@\213\240\3235\0\0\0"..., 832) = 832
fstat(18, {st_mode=S_IFREG|0755, st_size=588424, ...}) = 0
mmap(0x35d3a00000, 2682456, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 18, 0) = 0x7f0d08495000
mprotect(0x7f0d08521000, 2093056, PROT_NONE) = 0
mmap(0x7f0d08720000, 16384, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 18, 0x8b000) = 0x7f0d08720000
close(18)                               = 0
open("/usr/lib64/xulrunner-1.9.2/tls/x86_64/libasound.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/xulrunner-1.9.2/tls/x86_64", 0x7fff95eae6a0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/xulrunner-1.9.2/tls/libasound.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/xulrunner-1.9.2/tls", 0x7fff95eae6a0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/xulrunner-1.9.2/x86_64/libasound.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/xulrunner-1.9.2/x86_64", 0x7fff95eae6a0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/xulrunner-1.9.2/libasound.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/xulrunner-1.9.2", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/lib64/libasound.so.2", O_RDONLY) = 18
read(18, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\200\330\2\0\0\0\0\0"..., 832) = 832
fstat(18, {st_mode=S_IFREG|0755, st_size=956608, ...}) = 0
mmap(NULL, 3052072, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 18, 0) = 0x7f0d081ab000
mprotect(0x7f0d0828e000, 2093056, PROT_NONE) = 0
mmap(0x7f0d0848d000, 32768, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 18, 0xe2000) = 0x7f0d0848d000
close(18)                               = 0

==> it opens the one in /usr/lib64/xulrunner-1.9.2, but chokes on a few dependencies. 


Comparing the one in /usr/lib64 and /usr/lib64/xulrunner-1.9.2

[jeff@jeff-ubuntu Temp]$ ls -l /usr/lib64/libsqlite3.so.0.8.6 
-rwxr-xr-x. 1 root root 599248 Apr 19  2010 /usr/lib64/libsqlite3.so.0.8.6
[jeff@jeff-ubuntu Temp]$ ls -l /usr/lib64/xulrunner-1.9.2/libsqlite3.so 
-rwxr-xr-x. 1 root root 588424 Oct 27 12:13 /usr/lib64/xulrunner-1.9.2/libsqlite3.so

==> They are different
Comment 7 Krishnandu Sarkar 2010-11-26 22:43:56 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I started(opened) anjuta
2.
3.
Comment 8 Anish Calchand 2010-11-27 01:57:57 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.  Open Anjuta from Menu list
2.
3.
Comment 9 Mike Ma 2010-11-27 05:19:41 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.install openjdk
2.can't run anjuta
Comment 10 Kevin DeKorte 2010-11-27 09:54:59 EST
Just to see if rebuilding the rpm would solve the problem I downloaded anjuta-2.31.90.0-4.fc15.src.rpm from koji and then ran rpmbuild --rebuild on it. Installed the rpm and ran it, and it came up with the same error.
Comment 11 mirek 2010-11-27 18:06:40 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.bug during instalation anjuta editor
2. in gnome terminal Iwill instal anjuta and anjuta-devel with yum
3.the applications has instaled
4. first start anjuta make this bug
Comment 12 Jake 2010-11-28 22:22:07 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Downloaded it from Add/Remove Software
2. Tried to start it
3. Crash


Comment
-----
I have no clue what happened.
Comment 13 Scott Worley 2010-11-29 19:10:45 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Firefox open
2. Started Anjuta
3. Anjuta crashed before opening any windows
Comment 14 Paul Suppo 2010-11-30 18:46:57 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Perofmed FC13 to FC 14 upgrade. ... seems to have gone ok
2.Clicked on Anjuta IDE icon in the launcher
3.Program crash report came up
Comment 15 Andrzej 2010-12-01 12:17:04 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.On start
2.
3.
Comment 16 Victor Flores 2010-12-03 01:39:59 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Opened anjuta
2.Anjuta didn't start
3.
Comment 17 Sergei LITVINENKO 2010-12-03 15:04:29 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. run from menu KDE
2.
3.
Comment 18 Ben Williams 2010-12-03 18:11:48 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.yum install anjunta
2.click anjunta in the menu
3.
Comment 19 Stian Ellingsen 2010-12-05 06:54:04 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Start Anjuta.
2. Wait a few seconds.


Comment
-----
Anjuta only manages to show the loading screen before crashing.
Comment 20 Lucas088 2010-12-05 07:58:43 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.  Install Anjuta
2.  Execute App
3.  Fail


Comment
-----
Does anyone bother with testing?
Comment 21 Kevin DeKorte 2010-12-05 09:25:05 EST
Can the package maintainer please comment on this issue? Seems like a lot of people are hitting it and would be nice to know if it were being worked on at least.
Comment 22 rodrigo rodrigues 2010-12-07 23:31:18 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. install package in easylife
2.
3.
Comment 23 Marcello Divino 2010-12-08 02:41:59 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.launching anjuta 
2.appears splashscreen for 1 second
3.anjuta crashes
Comment 24 Florian Ludwig 2010-12-08 10:06:42 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. start anjuta
2. see the splash screen for a second
3. it crashes
Comment 25 Richard Guest 2010-12-08 15:04:11 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. $ yum install anjuta
2. $ anjuta
3.


Comment
-----
$ anjuta

** (anjuta:3026): WARNING **: Can't find libsqlite3.so file.

(anjuta:3026): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(anjuta:3026): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

** (anjuta:3026): WARNING **: Can't find libsqlite3.so file.

(anjuta:3026): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

** (anjuta:3026): WARNING **: Can't find libsqlite3.so file.

(anjuta:3026): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(anjuta:3026): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

** (anjuta:3026): CRITICAL **: gda_server_provider_supports_feature: assertion `GDA_IS_SERVER_PROVIDER (provider)' failed

** (anjuta:3026): WARNING **: Can't find libsqlite3.so file.

(anjuta:3026): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(anjuta:3026): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

(anjuta:3026): libanjuta-symbol-db-WARNING **: Could not open connection to DB_DIR=/home/richardg/.cache/anjuta;DB_NAME=.anjuta_sym_db


libanjuta-symbol-db-ERROR **: Opening global project under /home/richardg/.cache/anjuta
aborting...
Aborted (core dumped)
Comment 26 Johannes Schmid 2010-12-09 04:57:08 EST
Duplicate of bug #658471
Comment 27 Kevin DeKorte 2010-12-09 13:22:31 EST
Always annoys me when a lower bug# is declared a duplicate of a higher bug #.
Comment 28 Johannes Schmid 2010-12-09 13:37:15 EST
As I am not able to make real duplicates (above is just a link) I wanted to point to the bug with the most information available. Feel free to set "Duplicate" in the correct order if you can.
Comment 29 dvidunov 2010-12-09 16:00:50 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
do not start
Comment 30 Kevin DeKorte 2010-12-09 17:34:17 EST
Appears to be fixed by upgrading libgda to 1:4.2.2-1, which is currently found in updates-testing

yum --enablerepo=updates-testing update libgda
Comment 31 Sergei LITVINENKO 2010-12-10 12:54:53 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Start anjuta
2.
3.


Comment
-----
>> yum --enablerepo=updates-testing update libgda

do not help
Comment 32 Luc Chante 2010-12-12 13:20:59 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Anjuta does not start.
2.
3.
Comment 33 Davey O'Brien 2010-12-12 16:04:15 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Run the application (It has never run successfully before).
2.
3.
Comment 34 lucasmartinho 2010-12-12 19:22:42 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Not open
2.
3.
Comment 35 lucasmartinho 2010-12-12 19:55:58 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Exits , and no open
2.
3.
Comment 36 Vadim Lipovetsky 2010-12-13 05:23:29 EST
Package: anjuta-1:2.31.90.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Execute Anjuta IDE
2. Crash .
Comment 37 Gregor Hlawacek 2010-12-13 05:47:21 EST
The suggested update of libgda does not solve the issue.
Comment 38 Jean Gobin 2010-12-13 10:11:43 EST
Try setting LD_LIBRARY_PATH and start from the CLI



(Of course, if you're running 32bits, adapt!)


export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/lib:/usr/lib:/usr/lib64
anjuta &

It works in my case. I haven't tried the libgda upgrade yet.

J.
Comment 39 Johannes Schmid 2010-12-13 11:30:59 EST
Marking as duplicate of bug 658471 as this is the one where the final solution is discussed.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 658471 ***
Comment 40 Johannes Schmid 2011-02-16 16:03:21 EST
*** Bug 668309 has been marked as a duplicate of this bug. ***
Comment 41 Johannes Schmid 2011-02-21 16:58:26 EST
*** Bug 678736 has been marked as a duplicate of this bug. ***
Comment 42 Johannes Schmid 2011-03-14 04:44:01 EDT
*** Bug 684668 has been marked as a duplicate of this bug. ***
Comment 43 Johannes Schmid 2011-05-31 03:39:29 EDT
*** Bug 709135 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.