Bug 657388 - No sound with Realtek ALC888 (Intel 82801I)
No sound with Realtek ALC888 (Intel 82801I)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-25 12:16 EST by Dominick Grift
Modified: 2011-01-03 08:36 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-26 11:48:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dominick Grift 2010-11-25 12:16:51 EST
Description of problem:
Everything looks fine, except there is no sound coming out of the speakers.

Version-Release number of selected component (if applicable):
atleast 2.6.35.9-62.fc14.x86_64 and newer ( i also tried todays F15 rc1 )

How reproducible:
Install F14
  
Actual results:
There is no sound coming out of the speakers.

Expected results:
Sound

Additional info:
Works fine with F13 kernels!

$ dmesg | grep -i alsa
[   32.364515] ALSA sound/pci/hda/patch_realtek.c:1308: SKU: Nid=0x1d sku_cfg=0x40148a05
[   32.364521] ALSA sound/pci/hda/patch_realtek.c:1310: SKU: port_connectivity=0x1
[   32.364525] ALSA sound/pci/hda/patch_realtek.c:1311: SKU: enable_pcbeep=0x1
[   32.364528] ALSA sound/pci/hda/patch_realtek.c:1312: SKU: check_sum=0x00000004
[   32.364532] ALSA sound/pci/hda/patch_realtek.c:1313: SKU: customization=0x0000008a
[   32.364536] ALSA sound/pci/hda/patch_realtek.c:1314: SKU: external_amp=0x0
[   32.364539] ALSA sound/pci/hda/patch_realtek.c:1315: SKU: platform_type=0x1
[   32.364543] ALSA sound/pci/hda/patch_realtek.c:1316: SKU: swap=0x0
[   32.364547] ALSA sound/pci/hda/patch_realtek.c:1317: SKU: override=0x1
[   32.364624] ALSA sound/pci/hda/hda_codec.c:4435: autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0)
[   32.364628] ALSA sound/pci/hda/hda_codec.c:4439:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   32.364633] ALSA sound/pci/hda/hda_codec.c:4443:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[   32.364638] ALSA sound/pci/hda/hda_codec.c:4444:    mono: mono_out=0x0
[   32.364641] ALSA sound/pci/hda/hda_codec.c:4447:    dig-out=0x11/0x1e
[   32.364645] ALSA sound/pci/hda/hda_codec.c:4455:    inputs: mic=0x18, fmic=0x12, line=0x1a, fline=0x0, cd=0x0, aux=0x0
[   32.366178] ALSA sound/pci/hda/patch_realtek.c:1358: realtek: No valid SSID, checking pincfg 0x40148a05 for NID 0x1d
[   32.366183] ALSA sound/pci/hda/patch_realtek.c:1374: realtek: Enabling init ASM_ID=0x8a05 CODEC_ID=10ec0888
bash: __git_ps1: command not found

$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
bash: __git_ps1: command not found

$ cat /proc/asound/card0/codec* | grep 'Codec'
Codec: Realtek ALC888
Comment 1 Kyle McMartin 2010-11-25 12:29:45 EST
Additional info from IRC:
http://www.fpaste.org/Buuc/
http://www.fpaste.org/UNR2/
Comment 2 Kyle McMartin 2010-11-25 13:11:50 EST
commit eb42269565c9f9ac89437883dc390e5b62739291
Author: Kyle McMartin <kyle@mcmartin.ca>
Date:   Thu Nov 25 12:44:26 2010 -0500

    Revert "ALSA: hda - Fix ALC882 DAC connections in auto mode"
    
    This reverts commit 489008cd58740fe3842822681d33bf87c07c3412.
    
    Conflicts:
    
        sound/pci/hda/patch_realtek.c

commit d97719baa526a52dd9f4f4bd34b7bb5ff5aee737
Author: Kyle McMartin <kyle@mcmartin.ca>
Date:   Thu Nov 25 12:43:46 2010 -0500

    Revert "ALSA: hda - Remove superfluous external amp setup for ALC888"
    
    This reverts commit ef5dbbccbbfa7d2211fa8efcc095a9f4a7912dda.

Fixed it, so it's one of those two reverted commits which broke it between 2.6.34 and 2.6.35.9.
Comment 3 Kyle McMartin 2010-11-25 13:32:33 EST
commit d97719baa526a52dd9f4f4bd34b7bb5ff5aee737
Author: Kyle McMartin <kyle@mcmartin.ca>
Date:   Thu Nov 25 12:43:46 2010 -0500

    Revert "ALSA: hda - Remove superfluous external amp setup for ALC888"

    This reverts commit ef5dbbccbbfa7d2211fa8efcc095a9f4a7912dda.

Apparently this fixes it. Weird. :/
Comment 4 Kyle McMartin 2010-11-25 14:11:01 EST
http://lkml.org/lkml/2010/11/25/318
Comment 5 Kyle McMartin 2010-11-26 11:18:45 EST
Upstream fix will be something like this:
http://kyle.fedorapeople.org/hda_realtek-handle-unset-external-amp-bits.patch
Comment 6 Kyle McMartin 2010-11-26 11:48:37 EST
OK, fixed in the next 2.6.35/2.6.36 builds, and Takashi has queued the fix upstream. Thanks for testing.
Comment 7 Fedora Update System 2010-12-03 10:38:18 EST
kernel-2.6.35.9-64.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kernel-2.6.35.9-64.fc14
Comment 8 Fedora Update System 2010-12-04 19:42:23 EST
kernel-2.6.35.9-64.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 monz 2011-01-03 08:36:31 EST
Can this in any way be related to this bug https://bugzilla.redhat.com/show_bug.cgi?id=649163 ??

Note You need to log in before you can comment on or make changes to this bug.