Bug 657464 - guest is uppercase when host is lowercase
guest is uppercase when host is lowercase
Status: CLOSED DUPLICATE of bug 643317
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-11-26 02:54 EST by Suqin Huang
Modified: 2010-12-03 06:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 06:00:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2010-11-26 02:54:25 EST
Description of problem:


Version-Release number of selected component (if applicable):
kvm-83-215.el5

How reproducible:
sometimes

Steps to Reproduce:
1. boot guest with the following cmd:
/usr/libexec/qemu-kvm -drive file=/root/win2008r2-64-virtio.bak,index=0,if=virtio,media=disk,cache=none,format=qcow2,boot=on -net nic,vlan=0,model=virtio,macaddr=9a:2d:20:42:2a:60 -net tap,vlan=0,script=/usr/scripts/qemu-ifup-switch,downscript=no -m 2048 -smp 2,cores=1,threads=1,sockets=2 -cpu qemu64,+sse2 -vnc :0  -rtc-td-hack -M rhel5.6.0 -usbdevice tablet -boot c -monitor stdio -drive file=/root/storage.qcow2,index=1,media=disk
2. open cmd to issue command
3.
  
Actual results:
the output is uppercase, but host is lowercase.

Expected results:


Additional info:
1. Press CapsLk key to switch between lowercase and uppercase several times, the guest and host will sync.

2. guest:
Win2008R2

3. host:
kernel: 2.6.18-232.el5

cpu:
processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 26
model name	: Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping	: 4
cpu MHz		: 1600.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 3
cpu cores	: 4
apicid		: 7
fpu		: yes
fpu_exception	: yes
cpuid level	: 11
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx rdtscp lm constant_tsc ida nonstop_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr sse4_1 sse4_2 popcnt lahf_lm
Comment 2 Gerd Hoffmann 2010-12-02 03:29:50 EST
Please restest with kvm-83-218.el5
Comment 3 Suqin Huang 2010-12-02 23:56:59 EST
can not reproduce in kvm-83-218.el5
Comment 4 Gerd Hoffmann 2010-12-03 06:00:47 EST

*** This bug has been marked as a duplicate of bug 643317 ***

Note You need to log in before you can comment on or make changes to this bug.