Bug 657487 - perl-IPC-Run3 source rpm doesn't build
Summary: perl-IPC-Run3 source rpm doesn't build
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-IPC-Run3
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Petr Pisar
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Keywords: EasyFix
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-26 09:12 UTC by Sergio Rubio
Modified: 2012-11-08 18:52 UTC (History)
4 users (show)

(edit)
Cause: 
  Building binary RPM package from source perl-IPC-Run3 RPM
  package without installed perl-Time-HiRes.
Consequence: 
  The build fails when performing tests due to missing
  Time::HiRes perl module.
Fix: 
  `perl(Time::HiRes)' has been added to build-time
   dependencies of perl-IPC-Run3 package.
Result: 
   perl-Time-HiRes source package can be rebuilt now.
Clone Of:
(edit)
Last Closed: 2012-11-08 18:52:35 UTC


Attachments (Terms of Use)
mock build.log (7.50 KB, text/x-log)
2010-11-26 09:13 UTC, Sergio Rubio
no flags Details
add missing buildreq (875 bytes, patch)
2010-11-26 09:14 UTC, Sergio Rubio
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1440 normal SHIPPED_LIVE perl-IPC-Run3 bug fix update 2012-11-08 23:50:01 UTC
Red Hat Bugzilla 870089 None None None Never

Internal Trackers: 870089

Description Sergio Rubio 2010-11-26 09:12:41 UTC
Description of problem:
Rebuilding perl-IPC-Run3 fails


Version-Release number of selected component (if applicable):
perl-IPC-Run3-0.043-3

How reproducible:
Always

Additional info:
Missing build req perl(Time:HiRes)?

Patch and build.log attached.

Comment 2 Sergio Rubio 2010-11-26 09:13:47 UTC
Created attachment 463024 [details]
mock build.log

Comment 3 Sergio Rubio 2010-11-26 09:14:20 UTC
Created attachment 463025 [details]
add missing buildreq

Comment 4 Petr Šabata 2010-11-26 09:23:34 UTC
Sergio,

you're correct, the spec should explicitly depend on perl(Time::HiRes).

Petr

Comment 16 errata-xmlrpc 2012-11-08 18:52:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1440.html


Note You need to log in before you can comment on or make changes to this bug.