Bug 657493 - [abrt] gitg-0.0.6-3.fc14: hide_header_details: Process /usr/bin/gitg was killed by signal 11 (SIGSEGV)
Summary: [abrt] gitg-0.0.6-3.fc14: hide_header_details: Process /usr/bin/gitg was kill...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gitg
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Bryan Kearney
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:64cbb2becbd29a9709bacffbc8a...
: 677731 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-26 09:31 UTC by Kamil Páral
Modified: 2013-01-10 10:46 UTC (History)
4 users (show)

Fixed In Version: gitg-0.0.8-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-02 22:31:33 UTC


Attachments (Terms of Use)
File: backtrace (21.89 KB, text/plain)
2010-11-26 09:31 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2010-11-26 09:31:16 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: gitg
component: gitg
crash_function: hide_header_details
executable: /usr/bin/gitg
kernel: 2.6.35.6-48.fc14.x86_64
package: gitg-0.0.6-3.fc14
rating: 4
reason: Process /usr/bin/gitg was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1290763624
uid: 500

How to reproduce
-----
1. I clicked on one file name listed in the Details pane.
2.
3.

Comment 1 Kamil Páral 2010-11-26 09:31:19 UTC
Created attachment 463030 [details]
File: backtrace

Comment 2 Chris Northwood 2010-12-13 11:13:10 UTC
Package: gitg-0.0.6-3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
It happened when attempting to view stashed commits

Comment 3 Sanne Grinovero 2010-12-30 13:26:34 UTC
Package: gitg-0.0.6-3.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. open a repository with some patches stashed (using "git stash")
2. use "down" key to browse to some changeset (in the WIP area)
3. change focus to "details area", and  browse with "down" key again up lo tatest (bottom) changed file -> segfault


Comment
-----
I can repdroduce it every time on this repository, not sure if it depends on current state.

Comment 4 Christoph Wickert 2011-04-21 21:12:53 UTC
*** Bug 677731 has been marked as a duplicate of this bug. ***

Comment 5 Christoph Wickert 2011-04-21 21:13:58 UTC
According to the changelog this should be fixed in 0.0.8

Comment 6 Fedora Update System 2011-04-21 21:28:59 UTC
gitg-0.0.8-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gitg-0.0.8-1.fc14

Comment 7 Fedora Update System 2011-04-22 21:19:21 UTC
Package gitg-0.0.8-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gitg-0.0.8-1.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gitg-0.0.8-1.fc14
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-05-02 22:31:28 UTC
gitg-0.0.8-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.