Bug 657496 - perl-Makefile-Parser source rpm rebuild failing
perl-Makefile-Parser source rpm rebuild failing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-Makefile-Parser (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Petr Pisar
Adam Kolář
: EasyFix
: 661798 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-26 04:35 EST by Sergio Rubio
Modified: 2014-03-03 19:28 EST (History)
6 users (show)

See Also:
Fixed In Version: perl-Makefile-Parser-0.211-2.el6
Doc Type: Bug Fix
Doc Text:
Cause: Building perl-Makefile-Parser source RPM package without installed perl-Time-HiRes package. Consequence: Build process fails on executing Makefile.PL. Fix: Build-time dependencies on MDOM::Document::Gmake, MDOM::Util, and Time::HiRes Perl modules have been declared in the RPM package. Result: It's possible to rebuild perl-Makefile-Parser source package in minimal environment.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 08:40:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mock build.log (55.11 KB, text/x-log)
2010-11-26 04:36 EST, Sergio Rubio
no flags Details
Add missing BuildRequires (1.37 KB, patch)
2011-06-03 04:30 EDT, Mathieu Bridon
no flags Details | Diff

  None (edit)
Description Sergio Rubio 2010-11-26 04:35:39 EST
Description of problem:
perl-Makefile-Parser source rpm rebuild failing. Missing buildreq CPAN?

Version-Release number of selected component (if applicable):
perl-Makefile-Parser-0.211-1.1

How reproducible:
Always


Additional info:
BuildRequire: perl(CPAN) solves this issue but introduces a new one. build.log attached.
Comment 1 Sergio Rubio 2010-11-26 04:36:36 EST
Created attachment 463035 [details]
mock build.log
Comment 3 Marcela Mašláňová 2010-12-02 07:39:36 EST
There is missing BuildRequires: perl(Time::HiRes). CPAN only tries to download Time::HiRes during the build time, which is not good.
Comment 4 Marcela Mašláňová 2010-12-14 06:11:21 EST
*** Bug 661798 has been marked as a duplicate of this bug. ***
Comment 5 Suzanne Yeghiayan 2011-02-15 16:45:41 EST
This issue was proposed for RHEL 6.1 FasTrack but did not get resolved in time.
It has been moved to RHEL 6.2 FasTrack.
Comment 8 Mathieu Bridon 2011-06-03 04:30:24 EDT
Created attachment 502756 [details]
Add missing BuildRequires

Here is a patch to fix the issue that applies on the latest RHEL6 SRPM, hoping that can help spee things up so it can be fixed for 6.2 :)
Comment 19 errata-xmlrpc 2013-06-04 08:40:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0899.html

Note You need to log in before you can comment on or make changes to this bug.