Bug 65751 - (G550) Open Office 1.0 crashes X sometimes
(G550) Open Office 1.0 crashes X sometimes
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-31 04:56 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-22 15:08:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
copy of the .xsession-errors after the first crash (1.60 KB, text/plain)
2002-06-01 14:24 EDT, Need Real Name
no flags Details
another .xsession-errors, this time after 3 attempts to make a crash (1.88 KB, text/plain)
2002-06-01 14:26 EDT, Need Real Name
no flags Details
copy of the XFree86.0.log just after the crash (23.68 KB, text/plain)
2002-06-01 14:29 EDT, Need Real Name
no flags Details
my fonts configuration (100.00 KB, application/x-tar)
2002-06-01 14:35 EDT, Need Real Name
no flags Details
ps -A output, called just before the last crash (2.01 KB, text/plain)
2002-06-01 14:37 EDT, Need Real Name
no flags Details
Default font server configuration file (1.14 KB, text/plain)
2002-08-12 06:38 EDT, Need Real Name
no flags Details
fonst.dir from usr/X11R6/lib/X11/fonts/TrueType/Fonts (see config) (42.65 KB, text/plain)
2002-08-12 06:41 EDT, Need Real Name
no flags Details
fonts.scale from /usr/X11R6/lib/X11/fonts/TrueType/Fonts (see config) (42.65 KB, text/plain)
2002-08-12 06:42 EDT, Need Real Name
no flags Details
directory listing (13.06 KB, text/plain)
2002-08-12 06:43 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-05-31 04:56:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
This is a situation that happens sometimes, not always.

The problem is in the Antialiasing (AA) rendering, I think.
What happens exactly is that when I try to import a powerpoint file into
OpenOffice (OO), the file is loaded correctly, but just when the presentation is
displayed for the first time, OO "restart" the X server, killing the current
session. Files are not saved, that's why I think this is X related, because when
OO crashes, it tries to restore the session on the next startup. This means no
signals are generated that OO can caught.

I have tested only the Italian OpenOffice 1.0 release, with red hat linux 7.3,
all updates via up2date.

I know that Red Hat doesn't support Open Office, so ignore this report if you feel.

One more think, the problem arises only under certain condition. I have a
Powerpoint file that makes this happenall the time, but Word and Excel files
tested are rendered correctly. More over, I can fix this by simply setting off
the AA rendering. When AA is off, I can import Powerpoint files, and after
restore AA rendering, that's another reason to think this is something related to X.

I repeat: only tested with the Italian version (you can get it from:
http://ftp.linux.it/pub/mirrors/openoffice/OOo_1.0.0_LinuxIntel_install_it.tar.gz)


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. set Anitaliasing on
2. load PowerPoint files
3. Crash
	

Actual Results:  X server crashes

Expected Results:  Power Point files displayed

Additional info:

OpenOffice.org 1.0, italian version
Workaround: disable Antialiasing, load Powerpoint files, enable Antialiasing
Comment 1 Need Real Name 2002-05-31 05:01:36 EDT
Ops, one more thing, I can submit the powerpoint files that makes X crash, but
they are copyrighted (not by me), so they should not be downloaded from others,
and that's something that I hate to say (and to do).

I can even try to write a power point presentation and reproduce the problem, but
i not have quick and easy access to powerpoint now.
Comment 2 Mike A. Harris 2002-06-01 04:09:04 EDT
Indeed, if X gets killed, then it is an X bug somewhere.  Definitely not
an OpenOffice bug.

Please do not attach copyright material to the bug report (illegal, I'd
have to have it removed from bugzilla), however if you are comfortable
with providing a URL link to some file which causes the same thing to
happen, that would be helpful.

Can you also please attach your X config file and X log file from after
a crash (without starting up X in the process as that causes the new X
to erases the log from the crash).
Comment 3 Need Real Name 2002-06-01 14:23:41 EDT
Ok, these are my log files.

The xsession-errors-crash is taken after a first start of the X server, init 5.

The xsession-errors-crash-2 was taken after the first crash. This time, OO
opened the same powerpoint file successfully for 3 times. The 4 time, X crashed
again.

I have some small powerpoint presentation here, all around 250k, and they are
opened successfully. I think there is a problem with the size of these files.
Failure are always around the 1.500k, i.e. opening a file larger than 1mb
crashes X. This can be the problem, giving the fact that OO loads the whole file
in memory, maybe it tries to render the presentation and fails, that's why I
never have a crash when I disable Antialiasing.

Another important thing I forgot to say, is that I use Microsoft fonts. they are
taken from an XP installation (now gone away from my computer! :). Follow an
attachment of the /etc/X11/fs/config file and of the fonts.dir/fonts.scale files
in the directory of these fonts.

As a side note, I have tried with both gnome and kde, gnome with kdeinit, or
WindowMaker (with and without kdeinit).

Comment 4 Need Real Name 2002-06-01 14:24:30 EDT
Created attachment 59225 [details]
copy of the .xsession-errors after the first crash
Comment 5 Need Real Name 2002-06-01 14:26:52 EDT
Created attachment 59226 [details]
another .xsession-errors, this time after 3 attempts to make a crash
Comment 6 Need Real Name 2002-06-01 14:29:14 EDT
Created attachment 59227 [details]
copy of the XFree86.0.log just after the crash
Comment 7 Need Real Name 2002-06-01 14:35:54 EDT
Created attachment 59228 [details]
my fonts configuration
Comment 8 Need Real Name 2002-06-01 14:37:52 EDT
Created attachment 59229 [details]
ps -A output, called just before the last crash
Comment 9 Need Real Name 2002-08-06 06:08:37 EDT
Sorry for the long time without news...

I have changed my video card, now I have a matrox G550, and OpenOffice to 1.0.1,
and all seem to get a bit better. But crashes continues in different places,
now they happen often when I scroll a page (specially if zooming is set to 200
or so), or when I move images or tables.

After several tests, I can say it's a matter of fonts. I gave a try to the
drivers released by matrox, and they gave me the same problem. Then, I removed
every entry in my X11/fs/config, and I start OpenOffice with some crash tests
(rapidly move up and down the page, crazy moves of tables and so on).

I only have crashes when I restore the windows XP fonts. Specially Arial and Times.

Now, I have removed these fonts, and taken the true type from a very old win98
machine, a test machine with nothing installed except windows 98 (no Office, no
StarOffice, only 300 megs original and useless windows stuff).

It seems that these true types have not problems under X.

I'm using OpenOffice for about 3 hours without an X crash, so this can be a
coincidence, but it seems that these fonts are really the solution.

More over, M$ gives away, and for free download and use, true types for the web,
and these are the same that usually are stored in Office documents. I don't have
these fonts, so I cannot say if they are the same of winXP, but win98 fonts are
ok for me.

Hope that help.
Comment 10 Mike A. Harris 2002-08-07 20:01:37 EDT
The info about fonts could be useful in determining the problem, but
I want to also clear up one thing, so there is no confusion.

Anything that results in the X server and or computer crashing, is
either 1) an X server bug or X driver bug, 2) kernel bug, or 3) hardware
bug (or flaky hardware or bad hardware combination)

It is possible that some fonts might be incorrect and/or buggy, and there
are some known buggy fonts in the wild, such as mtsorts.ttf  (sp?), but
if a font causes the X server to crash, wether or not it is a buggy font,
the X server or some component of it is also buggy, as it should never
allow bad input to crash it.

Comment 11 Mike A. Harris 2002-08-07 20:03:58 EDT
Also, just a note - please submit log files, etc. in the English language
only.  Some of the attached log files contain non-English entries, and
I am an English only speaker, so the information is somewhat useless to
me.

Comment 12 Mike A. Harris 2002-08-07 20:12:53 EDT
fonts_configs.tar - please don't tarball files, just attach each file
individually.  It is too much effort to download tarballs, uncompress
them, then keep track of them throughout the life of a bug report, or
alternatively download them every time you look at a bug report.

Comment 13 Need Real Name 2002-08-12 06:36:05 EDT
Ok, here follow the unpacked version of my font config directory.

Mike, where I can get a new build of the XFree package that you feel stable
enough for daily use in my system? The problem may reside in the mga drivers, I
think this is surely an X problem (refer to the sig 11 at the end of the XFree
log file).

About the logs, I will test with the english locale, if I'll get more crashes, I
will post the logs in english here.
Comment 14 Need Real Name 2002-08-12 06:38:05 EDT
Created attachment 69986 [details]
Default font server configuration file
Comment 15 Need Real Name 2002-08-12 06:41:13 EDT
Created attachment 69987 [details]
fonst.dir from usr/X11R6/lib/X11/fonts/TrueType/Fonts (see config)
Comment 16 Need Real Name 2002-08-12 06:42:32 EDT
Created attachment 69988 [details]
fonts.scale from /usr/X11R6/lib/X11/fonts/TrueType/Fonts (see config)
Comment 17 Need Real Name 2002-08-12 06:43:29 EDT
Created attachment 69989 [details]
directory listing
Comment 18 Need Real Name 2002-11-21 05:03:34 EST
Hi mike,

Please, see Issuezilla issue 5447 for updates. This problem seem to be common to
other people with the mga drivers.

------ quoting ----------

Adding the following line to the mga Device section in XF86Config

  Option "XaaNoScreenToScreenColorExpandFill"

appears to fix this bug. See

http://cvs.debian.org/oo-deb/debian/Attic/README.Debian?logsort=date&cvsroot=debian-openoffice&rev=1.15&sortby=date&hideattic=1&search=None&hidecvsroot=1&diff_format=u

for more info.

-----------------------------------------------------------------------------

I'll try as soon as I can restart the X server. Will this affect the way the
antialiased fonts work?
--
neugens
Comment 19 Mike A. Harris 2002-11-24 05:57:05 EST
Please download and test the following driver:

Rename your existing driver /usr/X11R6/lib/modules/drivers/mga_drv.o
to mga_drv.o.orig first, then put the new one in place. Then edit
your config file, and remove any options that disable acceleration, 
etc.

ftp://people.redhat.com/mharris/test-drivers/mga_drv.o

Test it fully until you are sure it works or does not work.  Once I've
gotten feedback from that, I can explore the problem deeper, and try
to possibly fix the root cause

Thanks
Comment 20 Mike A. Harris 2002-12-22 15:08:32 EST
I've had other users report the Matrox mga driver crashing when using
Openoffice as well.  I've also had various other reports of Matrox G400,
G450, and G550 problems all of which had some similarity.  I have made
the above test driver in order to try and resolve this issue, and it works
for me properly.  I have now had several other Matrox users claim that this
driver fixes all of their crashing problems, as well as display corruption
problems using Xinerama, and some without Xinerama as well.

I'm assuming that this issue is also fixed by the new driver, and closing
it as fixed in RAWHIDE.  If you continue to experience problems with the mga
driver, and rawhide XFree86 does not resolve them, please feel free to
reopen this bug report and provide updated information of your latest
results and I'd be happy to troubleshoot further to try and find a resolution.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.