Bug 657525 - rhnpush doesnt work
Summary: rhnpush doesnt work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 1.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space13
TreeView+ depends on / blocked
 
Reported: 2010-11-26 10:52 UTC by Petr Sklenar
Modified: 2011-02-08 08:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-08 08:42:02 UTC


Attachments (Terms of Use)
http_error_log , sw on postgre (3.66 KB, text/plain)
2010-11-26 10:53 UTC, Petr Sklenar
no flags Details

Description Petr Sklenar 2010-11-26 10:52:58 UTC
Description of problem:
I cannot push any package into sw

Version-Release number of selected component (if applicable):
sw.nightly woth oracle or with postgre
spacewalk-backend-1.3.14-1.el5


How reproducible:
always


Steps to Reproduce:
1. install sw
2. rhnpush one package

 
Actual results:
rhnpush zsh-html-4.2.6-5.el5.x86_64.rpm -u user -p pass
Internal Server Error


Expected results:
works well

Additional info:

Comment 1 Petr Sklenar 2010-11-26 10:53:36 UTC
Created attachment 463059 [details]
http_error_log , sw on postgre

Comment 2 Petr Sklenar 2010-11-26 11:12:40 UTC
sw on oracle behaves little bit different, I cannot find log like with sw on postgre: 

$ rhnpush zsh-4.2.6-3.el5.i386.rpm -vvv
Connecting to https://localhost/APP
url is https://localhost/PACKAGE-PUSH
Result codes: 200 OK
Computing checksum and package info. This may take some time ...
Package zsh-4.2.6-3.el5.i386.rpm Not Found on RHN Server -- Uploading
Uploading package zsh-4.2.6-3.el5.i386.rpm
Using POST request
Internal server error 500 Internal Server Error
Error pushing zsh-4.2.6-3.el5.i386.rpm: Error 500Error Message:
    Unable to load package
Error Class Code: 50
Error Class Info: Invalid information uploaded to the server (500)
1
Waiting 3 seconds and trying again...

$ getenforce 
Permissive
$ /etc/init.d/iptables status
Firewall is stopped.

Comment 3 Jan Pazdziora 2010-11-26 13:56:27 UTC
I believe that that

RHN 16129 2010/11/26 05:42:30 -04:00: ("DATABASE CONNECTION TO 'spaceschema' LOST", "Exception information: Database instance has no attribute 'dbh'")

error on PostgreSQL is caused by exhausted connections to the database. We probably should bump up the number of allowed sessions for the PostgreSQL server.

Comment 4 Jan Pazdziora 2010-12-27 07:15:42 UTC
Taking.

Petr, rhnpush seems to work fine both on Oracle and PostgreSQL in latest Spacewalk nightlies. Do you still see the problem on your installations?

Jan

Comment 5 Jan Pazdziora 2011-01-03 08:53:19 UTC
(In reply to comment #3)
> I believe that that
> 
> RHN 16129 2010/11/26 05:42:30 -04:00: ("DATABASE CONNECTION TO 'spaceschema'
> LOST", "Exception information: Database instance has no attribute 'dbh'")
> 
> error on PostgreSQL is caused by exhausted connections to the database. We
> probably should bump up the number of allowed sessions for the PostgreSQL
> server.

Actually, the problem was caused by osa-dispatcher issuing bad SQL and then opening another connection and not closing down the previous one. The osa-dispatcher was fixed in latest nightlies.

Comment 6 Tomas Lestach 2011-02-08 08:42:02 UTC
This bug has been fixed in Spacewalk 1.3.


Note You need to log in before you can comment on or make changes to this bug.