Bug 657541 - [abrt] SwTxtNode::impl_FmtToTxtAttr
Summary: [abrt] SwTxtNode::impl_FmtToTxtAttr
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: David Tardon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:723ac21d3b1f5e0c0f6504d476e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-26 12:18 UTC by Prof. S.J. Wilcox
Modified: 2010-12-02 19:07 UTC (History)
2 users (show)

Fixed In Version: openoffice.org-3.3.0-17.2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-02 19:07:26 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (64.40 KB, text/plain)
2010-11-26 12:18 UTC, Prof. S.J. Wilcox
no flags Details

Description Prof. S.J. Wilcox 2010-11-26 12:18:37 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/swriter.bin -writer file:///home/Steve/Downloads/Staffing%20Requirements.docx
component: openoffice.org
crash_function: operator()
executable: /usr/lib/openoffice.org3/program/swriter.bin
kernel: 2.6.35.6-48.fc14.i686.PAE
package: openoffice.org-writer-1:3.3.0-15.2.fc14
rating: 4
reason: Process /usr/lib/openoffice.org3/program/swriter.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1290770247
uid: 500

How to reproduce
-----
1.Writer crashed during manipulation of text within a document, subsequently recovered document ok
2.
3.

Comment 1 Prof. S.J. Wilcox 2010-11-26 12:18:40 UTC
Created attachment 463069 [details]
File: backtrace

Comment 2 David Tardon 2010-11-26 13:32:43 UTC
The crash involved joining two paragraphs (by pressing Del at end of a paragraph). With this hint, are you able to reproduce it?

Comment 3 Prof. S.J. Wilcox 2010-11-27 10:59:22 UTC
I was joining two paragraphs by pressing delete when writer crashed, although I can't reproduce it.

Comment 4 David Tardon 2010-11-27 14:48:23 UTC
got it

Comment 5 David Tardon 2010-11-27 15:07:41 UTC
fix committed, will be in > 3.3.0-17.2.fc14

Comment 6 Fedora Update System 2010-11-29 11:47:43 UTC
openoffice.org-3.3.0-17.2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-17.2.fc14

Comment 7 Fedora Update System 2010-11-29 21:35:04 UTC
openoffice.org-3.3.0-17.2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-17.2.fc14

Comment 8 Fedora Update System 2010-12-02 19:07:03 UTC
openoffice.org-3.3.0-17.2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.