Bug 657550 - selinux-policy-targeted 3.7.19-73.fc13 conflicts with all released 389-ds-base/admin versions
selinux-policy-targeted 3.7.19-73.fc13 conflicts with all released 389-ds-bas...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: 389-admin (Show other bugs)
13
All Linux
low Severity urgent
: ---
: ---
Assigned To: Rich Megginson
Fedora Extras Quality Assurance
: screened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-26 07:52 EST by Mitchell Berger
Modified: 2011-04-25 19:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-25 17:30:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mitchell Berger 2010-11-26 07:52:30 EST
Description of problem:
The policies for dirsrv and dirsrv-admin are in the process
of being moved from the 389-* packages to selinux-policy.
As a result, the new selinux-policy-targeted package has
added the following Conflicts line since it can't coexist
with previous versions of 389-*:

Conflicts:  389-ds-base < 1.2.7, 389-admin < 1.1.12

In Fedora 13, all of the 1.2.7 series of 389-ds-base packages
and all of the 1.1.12/1.1.13 series of 389-admin packages are
still in testing and have not been submitted in Bodhi for pushing
to the stable repo.

The selinux-policy update was properly flagged as a critical
path update, and somehow sufficient caution was not taken to
coordinate pushing it with pushing the new 389 packages.  As
a result, anyone with 389-ds installed cannot update their
system any longer because the new selinux-policy-targeted
package in the stable repo conflicts with all released versions
of the 389 packages.

Version-Release number of selected component (if applicable):
3.7.19-73.fc13

How reproducible:
100%

Steps to Reproduce:
1. If you already have 389-ds-base installed, try to upgrade.
   If you don't have 389-ds-base installed and have taken the
   new selinux-policy-targeted update, try to install 389-ds-base.
  
Actual results:
You will be unable to update your system (if you already have
389-ds-base) or will be unable to install 389-ds-base (if you
have already updated selinux-policy-targeted).

Expected results:
Package updates that add conflicts with previous versions of
other packages shouldn't be pushed to stable without the new
version of the other packages already being available in stable
or without them being pushed simultaneously.

Additional info:
Either the dirsrv-related changes to selinux-policy-targeted
need to be backed out until 389-ds 1.2.7 is ready for F13 and
a new release needs to be pushed out ASAP, or the 389 maintainers
need to declare 1.2.7 ready for F13 and push that our ASAP.
Comment 1 Miroslav Grepl 2010-11-26 08:16:42 EST
I have increased the karma to resolve this issue.

Mitchell,
thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.