Bug 657567 - epydoc support for restructuredtext formatting broken - blocking RHEL-6 builds
Summary: epydoc support for restructuredtext formatting broken - blocking RHEL-6 builds
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: epydoc
Version: 6.0
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
: 661780 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-26 14:05 UTC by Sergio Rubio
Modified: 2011-03-02 13:10 UTC (History)
8 users (show)

Fixed In Version: epydoc-3.0.1-6.el6
Doc Type: Bug Fix
Doc Text:
Cause: Bug in the summary extractor of reStructuredText - non existent attribute 'child.data' was referenced. Consequence: epydoc can hang during processing of reStructuredText which can break build process of dependant packages. Fix: 'child.data' was replaced by 'child'. Result: epydoc does not hang during processing of reStructuredText.
Clone Of:
Environment:
Last Closed: 2011-03-02 13:10:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fix restructuredtext formatting. (1.12 KB, patch)
2010-11-29 15:22 UTC, Jaroslav Škarvada
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0316 normal SHIPPED_LIVE epydoc bugfix update 2011-03-02 13:10:41 UTC

Description Sergio Rubio 2010-11-26 14:05:07 UTC
Description of problem:
Rebuilding srpm fails.

gcc -pthread -shared -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic build/temp.linux-x86_64-2.6/src/py_ssl.o -L/usr/lib64 -lnspr4 -lssl3 -lpython2.6 -o build/lib.linux-x86_64-2.6/nss/ssl.so
+ /usr/bin/python setup.py build_doc
running build_doc
running build
running build_py
running build_ext
running build_api_doc
creating build/doc
creating build/doc/html
/usr/bin/epydoc -v --html --docformat restructuredtext -o build/doc/html build/lib.linux-x86_64-2.6/nss
  [....................
UNEXPECTED ERROR:
'Text' object has no attribute 'data'
Use --debug to see trace information.
error: command '/usr/bin/epydoc' failed with exit status 3
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.TKUIJu (%build)
    Bad exit status from /var/tmp/rpm-tmp.TKUIJu (%build)
Child returncode was: 1
EXCEPTION: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target x86_64 --nodeps builddir/build/SPECS/python-nss.spec']
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.6/site-packages/mock/util.py", line 345, in do
    raise mock.exception.Error, ("Command failed. See logs for output.\n # %s" % (command,), child.returncode)
Error: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target x86_64 --nodeps builddir/build/SPECS/python-nss.spec']
LEAVE do --> EXCEPTION RAISED


Version-Release number of selected component (if applicable):
python-nss-0.8-3

How reproducible:
Always

Additional info:
Related bug #565627 ?

Comment 2 Tuomo Soini 2010-11-28 12:49:21 UTC
This is related to bug #578920 .
This seem to be bug in python-docutils which got updated after rhel6beta1 to buggy version.

Comment 3 John Dennis 2010-11-29 14:50:18 UTC
I'm fairly confident this problem was reported against the wrong component, this is not a python-nss failure but rather an epydoc failure as noted in the couple of bug reports mentioned above. Also if you google the error you'll discover many project's have had their builds fail because of the epydoc bug.

I have changed the component from python-nss to epydoc.

Comment 4 Jaroslav Škarvada 2010-11-29 15:22:20 UTC
Created attachment 463510 [details]
Fix restructuredtext formatting.

Comment 6 Dmitri Pal 2010-12-09 16:53:54 UTC
*** Bug 661780 has been marked as a duplicate of this bug. ***

Comment 14 Jaroslav Škarvada 2011-01-12 12:47:13 UTC
Fixed in epydoc-3.0.1-6.el6

Comment 16 Florian Nadge 2011-01-19 17:18:42 UTC
Please be so kind and add a few key words to the technical note of this
bugzilla entry using the following structure:

Cause:

Consequence:

Fix:

Result:


For details, see:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks

Comment 17 Florian Nadge 2011-01-19 17:18:42 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:

Consequence:

Fix:

Result:

Comment 18 Jaroslav Škarvada 2011-01-19 19:31:48 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,7 +1,7 @@
-Cause:
+Cause: Bug in the summary extractor of reStructuredText - non existent attribute 'child.data' was referenced.
 
-Consequence:
+Consequence: epydoc can hang during processing of reStructuredText which can break build process of dependant packages.
 
-Fix:
+Fix: 'child.data' was replaced by 'child'.
 
-Result:+Result: epydoc does not hang during processing of reStructuredText.

Comment 20 errata-xmlrpc 2011-03-02 13:10:46 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0316.html


Note You need to log in before you can comment on or make changes to this bug.