Bug 657572 - Finnish locale includes unnecessary, confusing trailing spaces in the abbreviated months
Summary: Finnish locale includes unnecessary, confusing trailing spaces in the abbrevi...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc
Version: 6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 6.1
Assignee: Jeff Law
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Keywords:
Depends On: 657266
Blocks: 747123 657570 727267 756082
TreeView+ depends on / blocked
 
Reported: 2010-11-26 14:34 UTC by Adrien Kunysz
Modified: 2018-11-28 21:50 UTC (History)
9 users (show)

(edit)
Clone Of: 657266
(edit)
Last Closed: 2012-06-20 12:08:11 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0763 normal SHIPPED_LIVE glibc bug fix and enhancement update 2012-06-19 20:35:39 UTC
Sourceware 12962 None None None Never

Description Adrien Kunysz 2010-11-26 14:34:42 UTC
This is a request to remove trailing whitespaces from abmon fi_FI locale in RHEL6.

Observed behaviour:

$ for i in `seq 1 12` ; do LANG=fi_FI.utf8 date -d `printf 2010%02d01 $i` +.%b. ; done
.tammi .
.helmi .
.maalis.
.huhti .
.touko .
.kesä  .
.heinä .
.elo   .
.syys  .
.loka  .
.marras.
.joulu .

Expected behaviour:

$ for i in `seq 1 12` ; do LANG=fi_FI.utf8 date -d `printf 2010%02d01 $i` +.%b. ; done
.tammi.
.helmi.
.maalis.
.huhti.
.touko.
.kesä.
.heinä.
.elo.
.syys.
.loka.
.marras.
.joulu.

Comment 1 Andreas Schwab 2010-12-01 12:29:21 UTC
This will break date formatting.

Comment 2 Göran Uddeborg 2010-12-01 23:05:46 UTC
Break date formatting?  Quite the contrary, it will fix date formatting.

When our application does the equivalent of

date +%d.%b.%Y

and gets spaces in the output, then I'm pretty sure almost everybody would agree the output is incorrect.  There should be no spaces there.

The only case I can imagine where things would break is if an application writes dates with abbreviated months in some kind of table in a context with a fixed-width font, and the application makes the assumption that all short versions of month names are of equal width.  That table would not line up.

But that assumption the application makes is incorrect.  It is incorrect in the sense that no standard says it should be that way.  And it is incorrect in the sense that several locales don't look that way, Greek, French, Welsh, and Thai to take a few examples.

Any such application, if there is any, needs to be fixed.  It should not be a reason to include spaces in the names of months in the locale definition.  The names of the months do not contain spaces.

Comment 5 Adrien Kunysz 2010-12-02 13:53:14 UTC
As discussed with Andreas Schwab and Marko Myllynen, this needs to go through the Finnish National Localization Steering Group as to decide whether these trailing spaces are necessary then upstream glibc if they approve of the change. As part of the group, Marko will raise that point and update this Bugzilla with the result. This is likely to take several months.

Comment 6 Adrien Kunysz 2010-12-02 16:34:31 UTC
FYI, coreutils handles variable-length %b properly (at least in recent versions): http://git.savannah.gnu.org/cgit/coreutils.git/tree/src/ls.c#n721

Comment 10 Marko Myllynen 2011-07-05 20:47:08 UTC
> As part of the group, Marko will raise that point and update this Bugzilla with
> the result. This is likely to take several months.

I've now filed an upstream report which, among other things, proposes to drop the trailing spaces and thus to follow other locales like Greek and French:

http://sourceware.org/bugzilla/show_bug.cgi?id=12962

Comment 22 errata-xmlrpc 2012-06-20 12:08:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0763.html


Note You need to log in before you can comment on or make changes to this bug.