Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 657602 - [EMC 6.1 bug] Hot add/remove of LUNs does not work thru sysfs for open-fcoe
Summary: [EMC 6.1 bug] Hot add/remove of LUNs does not work thru sysfs for open-fcoe
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 6.1
Assignee: Mike Christie
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-26 19:00 UTC by Wayne Berthiaume
Modified: 2011-02-09 17:28 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
open-fcoe
Last Closed: 2011-02-09 17:28:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wayne Berthiaume 2010-11-26 19:00:49 UTC
Description of problem:
I am unable to get the scan attribute in scsi_host to cause a scan of the SCSI bus to add or remove LUNs.

Version-Release number of selected component (if applicable):
modinfo() does not report a version for the module fcoe. The kernel is 2.6.32-71.4.1.el6.x86_64.

How reproducible:
Always

Steps to Reproduce:
1.add or remove a LUN presented to the open-fcoe host
2.run Linux command: echo "- - -" > /sys/class/scsi_host/host<n>/scan
3.
  
Actual results:
No errors reported. There is nothing in /var/log/messages to indicate a scan of the host bus has been performed. The device that was expected to be removed or added does not occur.

Expected results:
No errors. The rescan of the host bus should be evident in /var/log/messages and the target LUN added or removed.

Additional info:

Comment 2 Andrius Benokraitis 2010-11-29 05:32:06 UTC
Tom, please assign as needed, thanks!

Comment 3 Mike Christie 2010-12-30 04:28:38 UTC
The scan attr does not remove devices. It only adds new ones. It also only adds devices on targets/ports that are already discovered. To discover new devices on new targets you have to do a issue_lip first.

fcoe.ko does not have a issue_lip function in 6.0, so you can basically just add new devices on existing targets.

Comment 4 RHEL Program Management 2011-01-07 04:51:16 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 5 Andrius Benokraitis 2011-01-07 15:54:04 UTC
(In reply to comment #4)
> This request was evaluated by Red Hat Product Management for
> inclusion in the current release of Red Hat Enterprise Linux.
> Because the affected component is not scheduled to be updated
> in the current release, Red Hat is unfortunately unable to
> address this request at this time. Red Hat invites you to
> ask your support representative to propose this request, if
> appropriate and relevant, in the next release of Red Hat
> Enterprise Linux. If you would like it considered as an
> exception in the current release, please ask your support
> representative.


Please disregard this, as it was in error.

Comment 6 Suzanne Yeghiayan 2011-01-07 16:14:03 UTC
This request was erroneously denied for the current release of Red Hat
Enterprise Linux.  The error has been fixed and this request has been
re-proposed for the current release.

Comment 7 Ronald Pacheco 2011-01-13 18:10:15 UTC
Wayne,

Based on comment #3, can we close this?

Comment 8 Wayne Berthiaume 2011-01-18 16:05:17 UTC
I'll retest this based on comment #3.

Comment 9 Ronald Pacheco 2011-01-18 19:23:24 UTC
Thanks Wayne!

Comment 10 Mike Christie 2011-01-18 23:55:38 UTC
(In reply to comment #3)
> fcoe.ko does not have a issue_lip function in 6.0, so you can basically just
> add new devices on existing targets.

That last part is a mistake on my part. fcoe.ko does support issue_lip, so you can discover new targets.

Comment 11 Tom Coughlan 2011-02-09 17:28:53 UTC
Wayne,

I'll close this for now. Please re-test, and if your testing finds any problems, re-open this. 

Tom


Note You need to log in before you can comment on or make changes to this bug.