Bug 65763 - Wrong path for fonts in type-ghostscript.mgk
Wrong path for fonts in type-ghostscript.mgk
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ImageMagick (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-31 11:28 EDT by Neal D. Becker
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-25 17:49:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal D. Becker 2002-05-31 11:28:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
convert -verbose Test.svg Test.eps
convert: Unable to read font (/usr/share/ghostscript/fonts/n019003l.pfb) [No
such file or directory].


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.See above
2.
3.
	

Additional info:

The file /usr/X11R6/share/ImageMagick/type-ghostscript.mgk specifies
an invalid path for the fonts.
Comment 1 Aleksey Nogin 2002-06-25 17:48:19 EDT
This problem still exists in Rawhide (ImageMagick-5.4.6-2). 

The type-ghostscript.mgk should be changed either to use fonts from
ghostscript-fonts or to use fonts from urw-fonts (or may be supply both
type-ghostscript.mgk and type-urw.mgk)?

This is a pretty nasty bug since it has a potential to break scripts that do not
specify fonts explicitly (when, say, using -draw "text ...").

P.S. A similar problem existed in /usr/X11R6/share/ImageMagick/fonts.mgk in 7.2,
but there it was not as harmful since X fonts were used by default.
Comment 2 Karsten Hopp 2002-07-03 08:08:40 EDT
tested with latest ImageMagick and 
http://www.w3.org/Graphics/SVG/Test/20011026/text-text-BE-01-ps.html 
and confirmed that it works now

Note You need to log in before you can comment on or make changes to this bug.