Bug 65775 - Fails to build as normal user
Fails to build as normal user
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: mod_perl (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Gary Benson
David Lawrence
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-05-31 12:38 EDT by Enrico Scholz
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 15:39:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-05-31 12:38:09 EDT
Description of Problem:

When trying to rebuild the mod_perl package, the installation fails because it
tries to write outside the RPM_BUILD_ROOT:

--------
$ rpm --rebuild mod_perl-1.26-7.src.rpm
...

+ make pure_install INSTALLDIRS=vendor PREFIX=/var/tmp/mod_perl-root/usr
Warning: You do not have permissions to install into
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi-stdio at
/usr/lib/perl5/5.8.0/ExtUtils/Install.pm line 84.
mkdir
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi-stdio/auto/Apache:
Permission denied at /usr/lib/perl5/5.8.0/ExtUtils/Install.pm line 137
make: *** [pure_vendor_install] Error 255
error: Bad exit status from /var/tmp/rpm-tmp.31497 (%install)
    Bad exit status from /var/tmp/rpm-tmp.31497 (%install)
-----


Version-Release number of selected component (if applicable):

mod_perl-1.26-7
perl-5.8.0-4
apache-1.3.23-13

Note You need to log in before you can comment on or make changes to this bug.