Bug 657774 - [abrt] phatch-cli-0.2.7-1.fc13: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
Summary: [abrt] phatch-cli-0.2.7-1.fc13: Process /usr/bin/python was killed by signal ...
Keywords:
Status: CLOSED DUPLICATE of bug 646035
Alias: None
Product: Fedora
Classification: Fedora
Component: phatch
Version: 13
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Narasimhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c03af573588b18576058fc0dbdc...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-27 20:06 UTC by FC_rules
Modified: 2011-03-23 17:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-23 17:52:31 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (28.81 KB, text/plain)
2010-11-27 20:06 UTC, FC_rules
no flags Details

Description FC_rules 2010-11-27 20:06:04 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: /usr/bin/python /usr/bin/phatch
component: phatch
executable: /usr/bin/python
kernel: 2.6.34.7-61.fc13.i686.PAE
package: phatch-cli-0.2.7-1.fc13
rating: 4
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
time: 1290888111
uid: 500

How to reproduce
-----
1.Opened phatch.
2.Opened a saved command list for resizing picures.
3.Tried to change the dpi for resizing picures and phatch crashed.

Comment 1 FC_rules 2010-11-27 20:06:07 UTC
Created attachment 463270 [details]
File: backtrace

Comment 2 Fedora Admin XMLRPC Client 2011-02-13 02:58:10 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Narasimhan 2011-03-23 15:03:28 UTC
I tried the sequence of steps for a png image in Fedora 14. Doesn't crash  for me. Also for a jpg image i get this error which has been filed here 629078.

Can you confirm whether the crash is observed in Fedora 14?

Comment 4 FC_rules 2011-03-23 17:47:23 UTC
I have just installed FC14, last weekend. I tried now (to add a logo on some pics) and it keeps crashing, but as you said like in #629078#. See below more info:


api.py:780:apply_actions_to_photo:AttributeError: 'NoneType' object has no attribute 'close'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/phatch/pyWx/gui.py", line 701, in on_menu_tools_execute
    self._execute(actionlist)
  File "/usr/lib/python2.7/site-packages/phatch/pyWx/gui.py", line 300, in _execute
    update=self._send_update_event, **keyw)
  File "/usr/lib/python2.7/site-packages/phatch/core/api.py", line 729, in apply_actions_to_photos
    is_done, image_index, repeat)
  File "/usr/lib/python2.7/site-packages/phatch/core/api.py", line 780, in apply_actions_to_photo
    photo.close()
AttributeError: 'NoneType' object has no attribute 'close'

Local variables in innermost frame:
repeat: 1
image_index: 0
photo: None
cache: {}
is_done: <bound method Action.is_done of <actions.save.Action object at 0x93da0ac>>
actions: [<actions.text.Action object at 0x93da9ec>, <actions.save.Action object at 0x93da0ac>]
image_info: {'weekdayname': 'Tuesday', 'foldername': u'27.04.10', 'second': 2, ....................................................................... 'type': u'jpg', 'weekday': 1}
info_not_file: <lib.metadata.InfoExtract instance at 0x93e432c>
result: {'answer': u'skip', 'skip': True, 'abort': False, 'stop_for_errors': True, 'last_answer': u'skip'}
read_only_settings: <lib.odict.ReadOnlyDict instance at 0x93e44ec>
report: []
skip_existing_images: False

Comment 5 FC_rules 2011-03-23 17:49:52 UTC
I added some info now with abrt and it seems it's the same problem on FC 14 as in bug: #646035#

(In reply to comment #4)
> I have just installed FC14, last weekend. I tried now (to add a logo on some
> pics) and it keeps crashing, but as you said like in #629078#. See below more
> info:
> 
> 
> api.py:780:apply_actions_to_photo:AttributeError: 'NoneType' object has no
> attribute 'close'
> 
> Traceback (most recent call last):
>   File "/usr/lib/python2.7/site-packages/phatch/pyWx/gui.py", line 701, in
> on_menu_tools_execute
>     self._execute(actionlist)
>   File "/usr/lib/python2.7/site-packages/phatch/pyWx/gui.py", line 300, in
> _execute
>     update=self._send_update_event, **keyw)
>   File "/usr/lib/python2.7/site-packages/phatch/core/api.py", line 729, in
> apply_actions_to_photos
>     is_done, image_index, repeat)
>   File "/usr/lib/python2.7/site-packages/phatch/core/api.py", line 780, in
> apply_actions_to_photo
>     photo.close()
> AttributeError: 'NoneType' object has no attribute 'close'
> 
> Local variables in innermost frame:
> repeat: 1
> image_index: 0
> photo: None
> cache: {}
> is_done: <bound method Action.is_done of <actions.save.Action object at
> 0x93da0ac>>
> actions: [<actions.text.Action object at 0x93da9ec>, <actions.save.Action
> object at 0x93da0ac>]
> image_info: {'weekdayname': 'Tuesday', 'foldername': u'27.04.10', 'second': 2,
> ....................................................................... 'type':
> u'jpg', 'weekday': 1}
> info_not_file: <lib.metadata.InfoExtract instance at 0x93e432c>
> result: {'answer': u'skip', 'skip': True, 'abort': False, 'stop_for_errors':
> True, 'last_answer': u'skip'}
> read_only_settings: <lib.odict.ReadOnlyDict instance at 0x93e44ec>
> report: []
> skip_existing_images: False

Comment 6 Narasimhan 2011-03-23 17:52:31 UTC

*** This bug has been marked as a duplicate of bug 646035 ***


Note You need to log in before you can comment on or make changes to this bug.