Bug 65782 - Anaconda probes hardware despite noprobe and text options.
Anaconda probes hardware despite noprobe and text options.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-31 13:35 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-31 13:35:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
When installing RedHat Linux 7.3 anaconda probes video hardware even when you
specify the text mode and noprobe options.  This causes some (relatively new)
Compaq Proliant servers with Cirrus Logic video cards to lock up completely
requiring a cold boot (all keyboard functions cease, ctrl-alt-delete doesn't
work, magic sysrq doesn't work, etc..).  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to install redhat linux on a compaq proliant with a cirrus logic video card.
2. Watch installer try to probe video hardware despite using the noprobe option.
3. Waste an entire day trying to modify anaconda so it skips the monitor probing
just to have it fail when it goes to install packages.  And look like a total
ass to your boss.  (this is what I did and now my boss is skepical about moving
the servers to redhat because I couldn't get it to install)
	

Actual Results:  The server locks up completely requiring a cold boot.

Expected Results:  The installer should have skipped video probing when the
noprobe option was used and continued normally.

Additional info:
Comment 1 Need Real Name 2002-05-31 15:16:06 EDT
Sorry about the sarcasm, it's been a long day....
Comment 2 Michael Fulbright 2002-06-04 10:58:39 EDT
Do you know if its the mouse or monitor probe that is doing it?

If you change the lines in the 'anaconda' script that looks like:

videohw    = videocard.VideoCardInfo(skipDDCProbe = flags.test))

monitorhw  = monitor.MonitorInfo(fbDevice=fbdev, skipDDCProbe = flags.test)

and change the skipDDCProbe value from 'flags.test' to '1', then put that
anaconda script on a floppy and boot with 'updates' on the command line, see if
that helps.

I'd like to know what exactly is handing it because this shouldn't really
happen.  In the next release I'm adding a 'skipddc' probe option just in case.
Comment 3 Need Real Name 2002-06-04 13:47:43 EDT
I'm not sure if its getting stuck on video probing or not.  I tried manipulating
the script before to skip the mouse probing because I initially thought it was
locking up on the mouse probe but the machine continued to lock up.  After
playing with it for a while I'm sure it's being caused by the video hardware
probing.  The server locks up after the video card has been probed two times (it
doesn't seem to matter weather the monitor is the hardware being probed or not)
 I need to make a special trip out to exodus today and try out these anaconda
modifications.  I'll let you know how things turn out.
Comment 4 Need Real Name 2002-06-04 16:32:22 EDT
I tried out the changes that you suggested, changing the flags.test option to 1
resulted in video corruption and a lockup rather than just a lockup this time. 
BTW..  I found out the model of the server is a Compaq Proliant 1600.
Comment 5 Need Real Name 2002-06-04 16:45:10 EDT
Also, this appears to be a duplicate of bug #64827 the fix for that bug didn't
work for me either.
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=64827
Comment 6 Need Real Name 2002-06-04 17:07:14 EDT
I can get the installer to move a lot farther along if I do the following:

comment out these lines in anaconda:
if 1:
    sys.stdout.write(    _("Probing for video card:   "))
    fbdev = None
    videohw    = videocard.VideoCardInfo(skipDDCProbe = flags.test)
                                 
    if videohw and videohw.primaryCard():
        sys.stdout.write(videohw.primaryCard().shortDescription()+'\n')
        fbdev = videohw.primaryCard().getDevice()
    else:
        sys.stdout.write(_("Unable to probe\n"))

    sys.stdout.write(    _("Skipping monitor probe: "))
    monitorhw  = monitor.MonitorInfo(fbDevice=fbdev, skipDDCProbe = 1)
    sys.stdout.write(monitorhw.shortDescription()+'\n')
    
    # only probe if we're installing a real box or
    # we're running in a virtual console and need to startup X server
    if not os.environ.has_key('DISPLAY') or flags.setupFilesystems:
        sys.stdout.write(_("Probing for mouse type:   "))
        mousehw.probe (frob = 1)
        sys.stdout.write(mousehw.shortDescription()+'\n')
    else:
        sys.stdout.write(_("Skipping mouse probe.\n"))
    

and these lines (starting at line 467):
    xcfg = xf86config.XF86Config(videohw.primaryCard(),
                                 monitorhw, mousehw, runres)


Anaconda will then start up without a problem and let you get up to the point of
package selection.  After you finish selecting your packages it errors out again
(I don't have the exact error but it should be instantly reproducable if you
make this change).  The installer errors out even if you opt not to install X11.
 I don't know enough about programming in python or anaconda's layout to get any
farther than this.  But I hope it might be usable information.
Comment 7 Need Real Name 2002-06-04 17:09:47 EDT
Is there any way to program in some kind of generic setting for the variables if
you try to skip probing?
Comment 8 Michael Fulbright 2002-06-06 12:53:10 EDT
If you put something on the boot command line, like:

linux mynoprobe

then in the python code you can do a test like:

if string.find('/proc/cmdline', 'mynoprobe) != -1:
   # they specified mynoprobe on the command line
else:
   # they did not specify it

I'm still confused why you are seeing problems in the first place.

I'll see if we have a proliant 1600 around here for me to look at.
Comment 9 Michael Fulbright 2002-07-15 12:56:11 EDT
Closing due to inactivty, please reopen if you have additional information to add.
Comment 10 Red Hat Bugzilla 2006-02-21 13:48:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.