Bug 657845 - Wrong spelling of Xfce in /usr/share/xsessions/xfce4.desktop
Summary: Wrong spelling of Xfce in /usr/share/xsessions/xfce4.desktop
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce-utils
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-28 12:39 UTC by hannes
Modified: 2011-01-13 08:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-12 23:34:30 UTC
Type: ---


Attachments (Terms of Use)

Description hannes 2010-11-28 12:39:38 UTC
Description of problem:
The file /usr/share/xsessions/xfce4.desktop contains a wrong name for Xfce:
[Desktop Entry]
Encoding=UTF-8
Type=XSession
Exec=startxfce4
TryExec=startxfce4
Name=XFce 4
Name[eo]=Facoj 4
Name[pa]=XFce ੪
Name[sv]=Xfce 4
[...]

The name should be Xfce 4 and not XFce 4. I think that is the reason why the name of Xfce is wrongly displayed in gdm.

Version-Release number of selected component (if applicable):
xfce-utils-4.6.2-2.fc14.x86_64

How reproducible:
always

Steps to Reproduce:
1. Wrong Xfce name in gdm session dialog
  
Actual results:


Expected results:
Xfce spelled right.

Additional info:

Comment 1 Kevin Fenzi 2010-11-28 18:06:53 UTC
This is easy to fix, but at the same time it might be good to fix the comment too, which is currently: 

Comment=The Cholesterol Free Desktop Environment, version 4. A desktop environment reminiscent of CDE

However, it's translated, so not sure how to retranslate a new line. 
I'd suggest something like: 

Comment=A lightweight, and fully featured desktop environment

Thoughts?

Comment 2 hannes 2011-01-12 21:40:59 UTC
Sounds good to me.

Comment 3 Kevin Fenzi 2011-01-12 23:34:30 UTC
This is fixed in rawhide with the 4.7 landing... 

The comment is now: 

Use this session to run Xfce as your desktop environment

Which isn't so great. ;) I'd say if we want that changed tho, we should look at fixing it upstream so they can translate it. ;)

Comment 4 Christoph Wickert 2011-01-13 08:21:01 UTC
I don't think it's bad, the comment is only shown on mouseover and the dropdown should have "Xfce4 Session", right?

Ether way, I have ditched the custom file and used the upstream one, so all changes should happeb upstream. If we want to change "Xfce session" to just "Xfce", we could do this easily, too.


Note You need to log in before you can comment on or make changes to this bug.