Bug 657851 - python-visual should require libglademm24
Summary: python-visual should require libglademm24
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-visual
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Thomas Spura
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-28 13:22 UTC by Darryl L. Pierce
Modified: 2015-06-22 00:07 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-12-08 21:44:15 UTC


Attachments (Terms of Use)

Description Darryl L. Pierce 2010-11-28 13:22:41 UTC
Description of problem:

On installing python-visual, I wasn't able to run existing python code written against this library due to a missing dependency.


Version-Release number of selected component (if applicable):

(mcpierce@mcpierce-laptop:Podcast)$ rpm -q python-visual
python-visual-5.32-10.fc14.x86_64


How reproducible:

100%

Steps to Reproduce:
1. Install python-visual.
2. Attempt to run a simple python-visual program.

  
Actual results:

(mcpierce@mcpierce-laptop:~)$ ./test.py 
Traceback (most recent call last):
  File "./test.py", line 3, in <module>
    from visual import *
  File "/usr/lib64/python2.7/site-packages/visual/__init__.py", line 59, in <module>
    import cvisual
ImportError: libglademm-2.4.so.1: cannot open shared object file: No such file or directory


Expected results:

The program to run.


Additional info:

I manually installed libglademm24 and my applications worked as expected. So this is not a bug in python-visual's code but instead just means that the python-visual specfile should include a dependency on libglademm24.

Comment 1 Thomas Spura 2010-11-30 10:15:37 UTC
Strange, that rpm can't find that out by itself.

That's becauser I used to strip the *.so files to follow:
https://fedoraproject.org/wiki/Packaging:AutoProvidesAndRequiresFiltering#Arch-specific_extensions_to_scripting_languages

I'll just provide and require the cvisualmodule, so all other requires are ok and ask FPC for help...

Comment 2 Fedora Update System 2010-11-30 12:41:03 UTC
python-visual-5.40-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/python-visual-5.40-1.fc14

Comment 3 Fedora Update System 2010-11-30 15:22:35 UTC
python-visual-5.40-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/python-visual-5.40-2.fc14

Comment 4 Fedora Update System 2010-11-30 22:35:18 UTC
python-visual-5.40-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-visual'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/python-visual-5.40-2.fc14

Comment 5 Fedora Update System 2010-12-08 21:44:11 UTC
python-visual-5.40-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.