Bug 657864 - orinoco_cs BUG: sleeping function called from invalid context
Summary: orinoco_cs BUG: sleeping function called from invalid context
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 14
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-28 14:11 UTC by Matt Domsch
Modified: 2011-01-13 19:16 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-13 19:16:53 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Linux Kernel 23932 0 None None None Never

Description Matt Domsch 2010-11-28 14:11:50 UTC
Description of problem:
[  378.882649] orinoco_cs 0.15 (David Gibson <hermes.id.au>, Pavel Roskin <proski>, et al)
[  378.882928] BUG: sleeping function called from invalid context at arch/x86/mm/fault.c:1074
[  378.882946] in_atomic(): 0, irqs_disabled(): 1, pid: 1843, name: modprobe
[  378.882962] Pid: 1843, comm: modprobe Not tainted 2.6.35.6-48.fc14.i686 #1
[  378.882973] Call Trace:
[  378.883009]  [<c042ada5>] __might_sleep+0xc3/0xca
[  378.883036]  [<c07a9d3e>] do_page_fault+0x146/0x275
[  378.883042]  [<c07a9bf8>] ? do_page_fault+0x0/0x275
[  378.883042]  [<c07a7acf>] error_code+0x73/0x78
[  378.883042]  [<d895802c>] ? orinoco_lock+0x1d/0x42 [orinoco]
[  378.883042]  [<d8959e13>] orinoco_interrupt+0x34/0x351 [orinoco]
[  378.883042]  [<c045e1d5>] ? __raw_local_irq_save+0x19/0x1e
[  378.883042]  [<c045e1d5>] ? __raw_local_irq_save+0x19/0x1e
[  378.883042]  [<c04834ba>] ? synchronize_irq+0x3c/0xab
[  378.883042]  [<c07a702d>] ? _raw_spin_unlock_irqrestore+0x13/0x15
[  378.883042]  [<c0483ac9>] ? disable_irq_nosync+0x51/0x57
[  378.883042]  [<c04840dd>] request_threaded_irq+0x12e/0x147
[  378.883042]  [<d8959ddf>] ? orinoco_interrupt+0x0/0x351 [orinoco]
[  378.883042]  [<c0693949>] pcmcia_request_irq+0x2f/0x41
[  378.883042]  [<d893e13f>] orinoco_cs_probe+0x76/0xee [orinoco_cs]
[  378.883042]  [<c0691ab5>] pcmcia_device_probe+0x133/0x210
[  378.883042]  [<c0650f00>] ? driver_sysfs_add+0x10/0x53
[  378.883042]  [<c0651262>] driver_probe_device+0x114/0x20d
[  378.883042]  [<c06513a3>] __driver_attach+0x48/0x64
[  378.883042]  [<c0650445>] bus_for_each_dev+0x42/0x65
[  378.883042]  [<c0650eee>] driver_attach+0x19/0x1b
[  378.883042]  [<c065135b>] ? __driver_attach+0x0/0x64
[  378.883042]  [<c0650b75>] bus_add_driver+0xc9/0x215
[  378.883042]  [<c05b0c32>] ? kset_find_obj+0x12/0x4e
[  378.883042]  [<c065157d>] driver_register+0x7c/0xdb
[  378.883042]  [<c06924b9>] pcmcia_register_driver+0xdd/0x11e
[  378.883042]  [<d8968000>] ? init_orinoco_cs+0x0/0x1e [orinoco_cs]
[  378.883042]  [<d896801c>] init_orinoco_cs+0x1c/0x1e [orinoco_cs]
[  378.883042]  [<c0401246>] do_one_initcall+0x4f/0x139
[  378.883042]  [<c0451e51>] ? blocking_notifier_call_chain+0x11/0x13
[  378.883042]  [<c04621a4>] sys_init_module+0x7f/0x19b
[  378.883042]  [<c07a73cc>] syscall_call+0x7/0xb
[  378.883042] BUG: unable to handle kernel NULL pointer dereference at 00000030


Version-Release number of selected component (if applicable):
Fedora 14 released kernel, 2.6.35.6-48.fc14.i686

How reproducible:
always (2 different systems, 2 different orinico_cs cards

Steps to Reproduce:
1. Boot Fedora 14 Live
  
Actual results:
System fails to boot with orinoco_cs card installed, due to kernel oopses.  Systems boots if card removed.  System boots if Fedora 13 errata kernels are used.

Expected results:
system boots, card works

Additional info:

Comment 1 Matt Domsch 2010-11-28 14:13:04 UTC
If Fedora has no specific patches in this area,  can file it with upstream bugzilla.

Comment 2 Matt Domsch 2010-11-28 19:42:39 UTC
Filed upstream.

Comment 3 Kyle McMartin 2010-12-09 23:20:24 UTC
Thanks Matt. Please let us know when/if there is a fix to merge.

Comment 4 Kyle McMartin 2010-12-09 23:40:04 UTC
Ah, it already has been. Looks annoying enough that I committed to F-14. Will be in the next build.

regards, Kyle

Comment 5 Kyle McMartin 2010-12-10 00:03:20 UTC
Ok, copied the fix to F14/rawhide too.

Comment 6 John W. Linville 2011-01-13 19:16:53 UTC
Closing on bases of comment 4 and comment 5...


Note You need to log in before you can comment on or make changes to this bug.