Bug 657936 - On SSE4.1 CPU, build fails with complaint that SSE4.2 is not supported
On SSE4.1 CPU, build fails with complaint that SSE4.2 is not supported
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
14
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-28 14:27 EST by Steve Snyder
Modified: 2010-11-28 16:36 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-28 15:57:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use separate tests for SSE4.1 and SSE4.2 support. (670 bytes, patch)
2010-11-28 14:27 EST, Steve Snyder
no flags Details | Diff

  None (edit)
Description Steve Snyder 2010-11-28 14:27:27 EST
Created attachment 463368 [details]
Use separate tests for SSE4.1 and SSE4.2 support.

Description of problem:

The same #if test is used for both SSE4.1 snd SSE4.2 support.  On a CPU that supports SSE4.1 but not SSE4.2, the build tried to #include SSE4.2-specific file nmmintrin.h.  This stops the build with an #error compiler directive.

Version-Release number of selected component (if applicable):

qt-4.7.1-3.fc14.src.rpm

How reproducible:

Always

Steps to Reproduce:

1. Build with -march=native on a CPU that supports SSE4.1, but not SSE4.2
  
Actual results:

Build fails with: 'error: #error "SSE4.2 instruction set not enabled"'

Expected results

Build should test for SSE4.2 supports before including header file nmmintrin.h.

Additional info:
Comment 1 Kevin Kofler 2010-11-28 15:57:38 EST
Thank you for your bug report, analysis and patch! However, -march=native is not something we're likely to take non-upstream patches for, given that our packages are not even built with that option. I am sorry, but we try to limit deviation from upstream to a minimum, fixing only issues which actually affect Fedora binary packages.

Please report this to the upstream Qt bug tracker: http://bugreports.qt.nokia.com/
That way, everyone will benefit, including source-based distributions and people who directly build Qt from source. Adding the patch to our SRPM would only help people who are rebuilding our SRPMs with different flags as you are doing, getting the fix upstream will help both you and the much larger community building from upstream tarballs (or directly from upstream git).

Thank you for your understanding and cooperation.
Comment 2 Steve Snyder 2010-11-28 16:36:18 EST
I just tried to sign up for bug reporting at the URL above and got an error.  Tried a different web browser and got the same error.  Guess it's not me.

Oh, well.  I tried.  Maybe someone else can nudge Nokia about this.

-----------------------

HTTP Status 404 - Could not find servlet for: /plugins/servlet/gadgets/Signup!default.jspa

type Status report

message Could not find servlet for: /plugins/servlet/gadgets/Signup!default.jspa

description The requested resource (Could not find servlet for: /plugins/servlet/gadgets/Signup!default.jspa) is not available.
Apache Tomcat/6.0.20

Note You need to log in before you can comment on or make changes to this bug.