Bug 657941 - multilib wrapper header not installed on i686
Summary: multilib wrapper header not installed on i686
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libsigsegv
Version: rawhide
Hardware: x86_64
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-28 20:43 UTC by Edward Sheldrake
Modified: 2010-11-28 23:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-28 23:05:47 UTC
Type: ---


Attachments (Terms of Use)

Description Edward Sheldrake 2010-11-28 20:43:39 UTC
Description of problem:
The multilib conflict avoiding wrapper header is no longer used on 32bit x86, since whenever things stopped being built as i386. One header being the wrapper and one being the real header now causes a conflict.

There isn't a multilib conflict anymore (without the wrapper), between x86_64 and i686 at least, although it helps if the file timestamp is fixed:

touch -r src/sigsegv.h.in %{buildroot}%{_includedir}/sigsegv.h

Version-Release number of selected component (if applicable):
libsigsegv-2.9-1.fc15

How reproducible:
Always

Steps to Reproduce:
1. Try to install libsigsegv-devel-2.9-1.fc15.i686 and libsigsegv-devel-2.9-1.fc15.x86_64
2.
3.
  
Actual results:
multilib conflict on /usr/include/sigsegv.h

Expected results:
no conflict

Additional info:
Either %ix86 could be used instead of i386 in the .spec file, or drop the wrapper header and set the file timestamp.

Comment 1 Rex Dieter 2010-11-28 23:05:47 UTC
rpm shouldn't conflict on timestamps anymore, just content.

should be fixed in 2.9-2+


Note You need to log in before you can comment on or make changes to this bug.