Bug 657952 - Problem with wake up from sleep
Summary: Problem with wake up from sleep
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pm-utils
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-28 21:55 UTC by debesh
Modified: 2014-01-16 07:21 UTC (History)
8 users (show)

Fixed In Version: pm-utils-1.2.6.1-4.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-12 21:30:18 UTC


Attachments (Terms of Use)
output of pm-utils-bugreport-info.sh (5.64 KB, text/plain)
2010-12-01 04:58 UTC, debesh
no flags Details

Description debesh 2010-11-28 21:55:25 UTC
Description of problem:
When the laptop is left unattended for a long time and it goes to sleep mode, it becomes unresponsive during wake up. 

Version-Release number of selected component (if applicable):


How reproducible:
Everytime

Steps to Reproduce:
1.Leave computer unattended for more than the time set for the computer to go to sleep
2.Try to wake up
3.
  
Actual results:
Computer shows the fedora logo screen and becomes unresponsive

Expected results:
The computer should wake up normally

Additional info:

Comment 1 Jaroslav Škarvada 2010-11-30 13:02:06 UTC
Please try to run pm-suspend from command line, report the result and also please provide output of pm-utils-bugreport-info.sh.

Comment 2 debesh 2010-12-01 04:58:05 UTC
Created attachment 463898 [details]
output of pm-utils-bugreport-info.sh

Comment 3 debesh 2010-12-01 05:02:11 UTC
when I tried pm-suspend the computer became unresponsive with a blue screen with fedora logo 3 out of 4 times. It worked properly once though. 
When the computer becomes unresponsive the hard disk is spun down, but the status light on my laptop still remains in the active state.

Comment 4 Jaroslav Škarvada 2010-12-01 11:35:03 UTC
Maybe kernel problem. Please try:
echo mem > /sys/power/state

Comment 5 debesh 2010-12-01 18:15:19 UTC
It works perfectly fine. Both suspend and wake up operation is very fast and without problems.

Comment 6 Jaroslav Škarvada 2010-12-06 11:43:01 UTC
I spot one problem, please try following experimental build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2646520

Comment 7 debesh 2010-12-11 05:37:41 UTC
Thank you. It solves the problem.

Comment 8 Fedora Update System 2010-12-13 09:52:19 UTC
pm-utils-1.2.6.1-4.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/pm-utils-1.2.6.1-4.fc13

Comment 9 Fedora Update System 2010-12-13 20:02:18 UTC
pm-utils-1.2.6.1-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pm-utils'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/pm-utils-1.2.6.1-4.fc13

Comment 10 openfred 2011-01-14 10:42:58 UTC
This bug seems to be "official" for trying to solve the wakes-up issue.
There is another bug for the same issue: 501380
https://bugzilla.redhat.com/show_bug.cgi?id=501380
Maybe one the bug may be close ?

Please have a look to the tests I've done:
https://bugzilla.redhat.com/show_bug.cgi?id=501380#c30

Short: this new version of pm-utils (pm-utils-1.2.6.1-4.fc13) does not solve the problem wakes-up issue, in my particular case. But it is not worst...

Important:
I guess the problem may not be a wakes up issue, but rather a bad way to put the laptop in sleep mode (See Comment 30, link above)

Comment 11 Jaroslav Škarvada 2011-01-14 14:28:12 UTC
This bug was caused by typo in pm-utils, which leads to usage of s3 quirk in cases in which it shouldn't be used and it caused problems with wakeups on some systems. The bug 501380 seems to be another story.

Comment 12 Jaroslav Škarvada 2011-01-14 14:32:31 UTC
The pm-utils-1.2.6.1-4.fc13 is now in testing and waits for enough karma to be pushed into stable. Feel free to give it some positive karma at:

https://admin.fedoraproject.org/updates/pm-utils-1.2.6.1-4.fc13

After that this bug will be auto-closed.

Comment 13 Fedora Update System 2011-04-12 21:30:12 UTC
pm-utils-1.2.6.1-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.