Bug 657971 - [abrt] rhythmbox-0.13.1-2.fc14: Process /usr/bin/rhythmbox was killed by signal 11 (SIGSEGV)
Summary: [abrt] rhythmbox-0.13.1-2.fc14: Process /usr/bin/rhythmbox was killed by sign...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:17833f99bf7337e8652d890aefa...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-28 23:44 UTC by Bob Kashani
Modified: 2011-01-07 17:08 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-07 17:08:43 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (44.89 KB, text/plain)
2010-11-28 23:44 UTC, Bob Kashani
no flags Details

Description Bob Kashani 2010-11-28 23:44:38 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: rhythmbox
comment: This happens everytime!!!
component: rhythmbox
executable: /usr/bin/rhythmbox
kernel: 2.6.35.6-48.fc14.x86_64
package: rhythmbox-0.13.1-2.fc14
rating: 4
reason: Process /usr/bin/rhythmbox was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1290983931
uid: 500

How to reproduce
-----
1. Play mp3 file in rhythmbox
2. When song ends rhythmbox crashes
3.

Comment 1 Bob Kashani 2010-11-28 23:44:40 UTC
Created attachment 463387 [details]
File: backtrace

Comment 2 mikes.post.theme 2010-12-02 18:12:39 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
i finished playing a track and rhythmbox crashed. i'm using vlc player to play tracks now because of this issue, but i'm missing the library of rhythmbox.
may be also connected to another bug which i keep getting while rhythmbox is playing

Comment 3 Matthew Gardner 2010-12-07 04:30:49 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
I'm pretty sure this bug is in gstreamer, because the exact same thing happens in both rhythmbox and banshee.  I have some mp3 files with questionable headers, and on my install they crash both of these applications when I play them.  Only this specific set of files causes the crash - all other songs play just fine.

I'm not sure that this is the right place to file this bug, but this is where abrt sent it.  If you can tell me a better place to file the bug, I would appreciate it.  But after some extensive experimentation, I'm pretty sure the bug is in Fedora's packaging of gstreamer with these applications.

In case I wasn't clear on what is happening, here it is:
I do a fresh install of either rhythmbox or banshee.
I import a bunch of tracks, including two albums of mp3s with questionable headers.
I play any songs except the two questionable albums, and everything works just fine.
I play one of the questionable songs once, and it plays, but an exception is thrown and caught.
I play one of the songs again, and the program crashes.

This exact same thing happens in both rhythmbox and banshee, so I'm pretty sure it's a package that underlies both of them that is causing the problem.  I'm not sure what package that is, but someone who knows more than I do told me it is likely that gstreamer is the problem.

It's also notable that on another machine that I have with Fedora 14 installed, everything works just fine.  I don't know of any difference between the installation of the other machine I have and this one, because both were fresh installs of Fedora 14, but somehow the installation on this machine was corrupted or the packages aren't working right, because installing rhythmbox from yum leaves things still in a broken state.  Something is wrong with the Fedora packages somewhere, I'm just not sure where.

Comment 4 Matthew Gardner 2010-12-07 04:32:17 UTC
Abrt listed my report as a duplicate of this bug, but I am quite certain it is separate.  Maybe I will file a new bug report with this information in it.

Comment 5 Bob Kashani 2010-12-14 01:44:09 UTC
PackageKit/Yum just updated gstreamer to gstreamer-0.10.31-1.fc14.x86_64 and now rhythmbox no longer crashes. The time/progress bar doesn't move though it remains at the beginning but the counter does work correctly. Totem works PERFECTLY, no issues. :)

Comment 6 Kris Buytaert 2010-12-14 09:46:46 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Play song..
Wait till song ends and new song should start .. 
Crash 


I was hoping that the new gstreamer libs etc had fixed this ...  no such luck ..

Comment 7 Kris Buytaert 2010-12-14 09:47:41 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Play song..
Upon loading the next one .. 
Crash happens..

Comment 8 mikes.post.theme 2010-12-14 16:58:18 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
rhythmbox finished playing a track

Comment 9 Bob Kashani 2010-12-15 05:31:04 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


I rebooted my laptop and now rhythmbox works perfectly, no issues. The progressbar and time both work correctly, no crashes. Very strange. I've tried about 30 different mp3s and they all work.

Comment 10 Kris Buytaert 2010-12-15 08:40:44 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
this one happened when I tried removing an entry from the playlist.

Comment 11 Dovydas 2010-12-15 18:17:21 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Started Rhythmbox
2. Chose File->Import file, selected a file, pressed 'Import'
3. Crash happend

Comment 12 Maarten Blomme 2010-12-17 10:05:03 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. happend while playing songs over an ssh connection (files were on an other machine, accessed by ssh)

Comment 13 jackonweb 2010-12-18 02:53:20 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.The songs is  playing and rythymbox crashed suddenly for no reason.
2.
3.

Comment 14 Paul DeStefano 2010-12-21 17:57:28 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I double clicked on an MP3 file and RythmBox started to play it.
2. It started to play correctly.  But, I noticed that the buffer slider bar wasn't moving.  I tried to grab it and move it so as to fast forward through the audio file.  But, I couldn't move it.
3. I clicked the stop button and the file stopped playing.
4. I clicked the play button and this crash occured.

Comment 15 Nathanael Noblet 2010-12-22 16:56:13 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Open rhythmbox
2. Start playing a song (mp3)
3. Click next...

Reproduceable: always

Comment
-----
I have been playing with gstreamer git snapshots - however I've spent the last hour making sure everything I have installed is the latest released packages from fedora. 

It also crashes if I leave it play and its about to switch songs.

Also of note, I can't seek in the songs.

Comment 16 amturnip 2010-12-25 00:51:33 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Rhythmbox was playing one of the preset "radio" channels - Absolute Classic Rock Broadband.
2. I double-clicked another preset "radio" channel - NRK mP3.
3. Suddenly Rhythmbox went away.


Comment
-----
Later, I reinvoked Rhythmbox. I double-clicked NRK mP3, listened briefly, and then double-clicked Absolute Classic Rock Broadband and listened briefly. Then I tried to return to NRK mP3 and Rhythmbox crashed again.

Comment 17 Nathanael Noblet 2011-01-07 17:08:43 UTC
Installing gstreamer-plugins-ugly will fix the issue. The real bug is in ffmpeg which is provided by rpmfusion..


Note You need to log in before you can comment on or make changes to this bug.