Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 657990 - rhncfg-client get : returns exit code 0 even when fails.
Summary: rhncfg-client get : returns exit code 0 even when fails.
Keywords:
Status: CLOSED DUPLICATE of bug 627964
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Configuration Management
Version: 540
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2010-11-29 02:03 UTC by Dimitar Yordanov
Modified: 2012-03-19 16:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-19 16:40:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dimitar Yordanov 2010-11-29 02:03:11 UTC
Description of problem:
rhncfg-client  get : returns exit code 0 evem when fails

Version-Release number of selected component (if applicable):
rhncfg-client-5.9.27-1.el5sat

How reproducible:
Always

Steps to Reproduce:
1. Register server to satellite.
2. Create Configuration channel and subscribe the system to it.
2. rhncfg-client get some_file_that_does_not_exists
  
Actual results:
Not found on server: some_file_that_does_not_exists
Exit code equal to 0

Expected results:
Not found on server: some_file_that_does_not_exists
Exit code different than 0

Additional info:
Ex:
# rhncfg-client get /tmp/tmp/file_test_one
Deploying /tmp/tmp/file_test_one
# echo $?
0
# rhncfg-client get /tmp/tmp/file_test_one_
Not found on server: /tmp/tmp/file_test_one_
# echo $?
0

Comment 1 Aron Parsons 2011-03-11 22:12:09 UTC
Additionally, rhncfg-client exits with 0 when "verify" picks up differences.  This is not ideal when scripting with the utility and forces one to evaluate the text output of the utility.

Comment 2 Miroslav Suchý 2012-03-19 16:40:18 UTC

*** This bug has been marked as a duplicate of bug 627964 ***


Note You need to log in before you can comment on or make changes to this bug.